summaryrefslogtreecommitdiffstats
path: root/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-03 14:12:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 01:49:57 +0100
commit1ebc9f7807db09eb53d7f304c4d4126700c6b297 (patch)
tree42fd1e502522a40d2c2f002399515048b235405c /trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
parent5732f27c0e26d2fba84055858043018f5b458718 (diff)
downloadtde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.tar.gz
tde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.zip
*/*: 9999: Sanitise eclass/ebuild vars, drop set-trinityver and need-trinity
Uniform ebuild variable blocks according to skel.ebuild and by devmanual example Sort some DEPENDs, fix some DESCRIPTIONs Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild')
-rw-r--r--trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild b/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
index d873617f..0ab88508 100644
--- a/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
+++ b/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
@@ -1,26 +1,23 @@
+# Copyright 2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_TYPE="applications"
+TRINITY_MODULE_TYPE="applications"
inherit trinity-base-2
DESCRIPTION="K3b - internationalization translations"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
-
-need-trinity
-SLOT="${TRINITY_VER}"
-
-IUSE+=" +handbook"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+IUSE="+handbook"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DBUILD_MESSAGES=ON
-DBUILD_DOC="$(usex handbook)"
)
-
trinity-base-2_src_configure
}