summaryrefslogtreecommitdiffstats
path: root/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-27 03:12:05 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-27 23:02:37 +0000
commitcc3bceb0d70f3feafbe8d6902ba82a4062539ba1 (patch)
treed24803cc22fe29fd5adfb9b7d9c80843d4bc89d7 /trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
parente63e76c93c7b7637edbaae22861ee32700f497f7 (diff)
downloadtde-packaging-gentoo-cc3bceb0d70f3feafbe8d6902ba82a4062539ba1.tar.gz
tde-packaging-gentoo-cc3bceb0d70f3feafbe8d6902ba82a4062539ba1.zip
Live ebuilds: Add preliminary `K3b`, `K3b-i18n` and `eMoviX` ebuilds.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild')
-rw-r--r--trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild b/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
new file mode 100644
index 00000000..d1506d5a
--- /dev/null
+++ b/trinity-apps/k3b-i18n/k3b-i18n-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+inherit trinity-base-2
+
+DESCRIPTION="K3b - internationalization translations"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" +handbook"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_MESSAGES=ON
+ -DBUILD_DOC="$(usex handbook)"
+ )
+
+ trinity-base-2_src_configure
+}