summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbarcode
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-apps/kbarcode
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kbarcode')
-rw-r--r--trinity-apps/kbarcode/Manifest1
-rw-r--r--trinity-apps/kbarcode/kbarcode-14.0.12.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/Manifest b/trinity-apps/kbarcode/Manifest
index 84e99c35..aa09e7ec 100644
--- a/trinity-apps/kbarcode/Manifest
+++ b/trinity-apps/kbarcode/Manifest
@@ -1 +1,2 @@
DIST kbarcode-trinity-14.0.11.tar.xz 273692 BLAKE2B 3d2f4bd6dbddf3ec1d26323aa84c0362e12be74715443900c6b9f59990d8a8859eb1563540c7aadb1f97a73bca081c68d5d6d9d6150ec670a2c2c7df62cd232b SHA512 8354bf4085bea629171628ce450cfba3d95d47ee39118ad7ed89535be35e3d89ae27cfb1cd70917d269c2e157b3abb31046e6eb63ba6c7442124bd6a3af2c03f
+DIST kbarcode-trinity-14.0.12.tar.xz 273628 BLAKE2B 99a0da86bc7db39ca467770d3da78d852ed520dfe9c282083643982bdd55f1b2e15223253a028bfce67ccf426d03faac34156347b4c5b19c6e9479cfe7f0bad9 SHA512 3ed351dbd79bfcd09426e95d23b48014ff9d5202527e4f06904b067da2279e126758d1fd21574199ac9ec82bfefffc5eb156bd71d10295fe4b40e428bece7924
diff --git a/trinity-apps/kbarcode/kbarcode-14.0.12.ebuild b/trinity-apps/kbarcode/kbarcode-14.0.12.ebuild
new file mode 100644
index 00000000..cf806577
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-14.0.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+IUSE="javascript native-gnu-barcode"
+
+RDEPEND="
+ app-text/barcode
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native-gnu-barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}