summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbibtex
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/kbibtex
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kbibtex')
-rw-r--r--trinity-apps/kbibtex/Manifest1
-rw-r--r--trinity-apps/kbibtex/kbibtex-14.0.11.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/kbibtex/Manifest b/trinity-apps/kbibtex/Manifest
index 8a2e61d0..06cab88d 100644
--- a/trinity-apps/kbibtex/Manifest
+++ b/trinity-apps/kbibtex/Manifest
@@ -1 +1,2 @@
+DIST kbibtex-trinity-14.0.11.tar.xz 285632 BLAKE2B 7df410be4f7576cdf3818620b30d5a4771270f1783c9a8866b479ed3ea8725c94d925e09eea8f0646a524301acd9e16ef73597bc531ae8c863a9f6a0e32fae68 SHA512 71f976721aabfba0c58cb4fd430dc17ab8f3527c40bebdf4cd9c9812ed6a9333e98e6f21d257637348c76e0fb544feb36d22ed50db0d6bfbe77c0ddba7409350
DIST kbibtex-trinity-14.0.8.tar.xz 306836 BLAKE2B a481839285a942a4feb8a52489f805dac07e9e2ecd1ad5bbc07b77f785cc5ad276e73f0e6417ec1991c2941ba8ef21e69766aaf296f38655cb1c5ff9ad737004 SHA512 e10c2286655f366143d742dc16b8a8c2db81add08c3e5c8d4cb9c698a8f3399cc2a7c5e89975e8b1ce4f916ce6e10420feeb8f8073f168a5d25652c0e9fc5fc9
diff --git a/trinity-apps/kbibtex/kbibtex-14.0.11.ebuild b/trinity-apps/kbibtex/kbibtex-14.0.11.ebuild
new file mode 100644
index 00000000..2d0849b8
--- /dev/null
+++ b/trinity-apps/kbibtex/kbibtex-14.0.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de fr it pl ru"
+TRINITY_MODULE_TYPE="applications/office"
+inherit trinity-base-2
+
+DESCRIPTION="Bibliography editor for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="
+ dev-libs/libxslt
+ dev-libs/yaz
+ virtual/tex-base"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html
+ dev-tex/latex2rtf
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}