summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbiff
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-01 01:19:07 +0200
committerChris <xchrisx@uber.space>2020-04-01 14:48:07 +0200
commit0b5d85442a2f386c2687c11c2872f75c8fc7f9d9 (patch)
treea968a6fda6c08888c24afdb4f02f473c9f1bf7f2 /trinity-apps/kbiff
parent6fb5630e6709b3cb9fac8f189bca658f5489e14e (diff)
downloadtde-packaging-gentoo-0b5d85442a2f386c2687c11c2872f75c8fc7f9d9.tar.gz
tde-packaging-gentoo-0b5d85442a2f386c2687c11c2872f75c8fc7f9d9.zip
Live ebuilds: Add preliminary `KBiff` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/kbiff')
-rw-r--r--trinity-apps/kbiff/kbiff-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/kbiff/kbiff-9999.ebuild b/trinity-apps/kbiff/kbiff-9999.ebuild
new file mode 100644
index 00000000..925f82b2
--- /dev/null
+++ b/trinity-apps/kbiff/kbiff-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br cs da de el es et fi fr he hr hu is it ja
+ nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_TW"
+
+inherit trinity-base-2
+
+DESCRIPTION="Email notification utility for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" +ssl asus"
+
+# SSL support might need tdelibs build with +ssl USE.
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_SSL="$(usex ssl)"
+ -DWITH_MLED="$(usex asus)"
+ )
+
+ trinity-base-2_src_configure
+}