summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbiff
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-apps/kbiff
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kbiff')
-rw-r--r--trinity-apps/kbiff/Manifest1
-rw-r--r--trinity-apps/kbiff/kbiff-14.0.12.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/trinity-apps/kbiff/Manifest b/trinity-apps/kbiff/Manifest
index 95b3b1b9..74ee6d77 100644
--- a/trinity-apps/kbiff/Manifest
+++ b/trinity-apps/kbiff/Manifest
@@ -1 +1,2 @@
DIST kbiff-trinity-14.0.11.tar.xz 139260 BLAKE2B 5e15fb056d69d13d7e8d94a7552d3615e241802ef46a8100d9666a07a1a8c16d13a3d19e6a076f0c133621d1c5378e8a170cb7f07b85807c854ec9a88b7f1118 SHA512 232249a37e8016b2cf9a62686ed7612aa719c956b9d635d66c06235356ba74607aaf42ee710529f8b25d8c9f16d5abcba5dabef6e7ad8f28d45dd262911f2edd
+DIST kbiff-trinity-14.0.12.tar.xz 139228 BLAKE2B a4bfc8e6e1351769b1b2549fe4514871d866be25d2cd3ccedb005c907c20324615cdf8b32aa123382d50dfce7c395ce945d16bd43d1cd5a1686749ccbd187689 SHA512 2b318d53c1de85ab9f63e1aa94de37e3b98c76f87d4a6bf420fe9c0133f595f596af14ec6028fca1f6c39838a2ceab41a30e4bde6fe8aefaeae37c6034c38fad
diff --git a/trinity-apps/kbiff/kbiff-14.0.12.ebuild b/trinity-apps/kbiff/kbiff-14.0.12.ebuild
new file mode 100644
index 00000000..af41a816
--- /dev/null
+++ b/trinity-apps/kbiff/kbiff-14.0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br cs da de el es et fi fr he hr hu is it ja
+ nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_TW"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="Email notification utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="asus +ssl"
+
+# SSL support might need tdelibs build with +ssl USE.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_SSL="$(usex ssl)"
+ -DWITH_MLED="$(usex asus)"
+ )
+
+ trinity-base-2_src_configure
+}