summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kformula/kformula-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/kformula/kformula-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kformula/kformula-14.1.0.ebuild')
-rw-r--r--trinity-apps/kformula/kformula-14.1.0.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/trinity-apps/kformula/kformula-14.1.0.ebuild b/trinity-apps/kformula/kformula-14.1.0.ebuild
new file mode 100644
index 00000000..3d143231
--- /dev/null
+++ b/trinity-apps/kformula/kformula-14.1.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="kformula filters/kformula"
+TSM_EXTRACT_ALSO="lib interfaces doc"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="KOffice formula editor for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+handbook"
+
+DEPEND="~trinity-apps/koffice-libs-${PV}
+ ~trinity-base/kcontrol-${PV}"
+
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+src_prepare() {
+ local search_path="${TDEDIR}/${get_libdir}"
+ local libname dirname dirlist x
+ libname=""
+ for x in $KMCOPYLIB; do
+ if [ "${libname}" == "" ] ; then
+ libname="${x}"
+ else
+ dirname=$x
+ mkdir -p ${dirname}
+ pushd ${dirname}
+ if [ ! "$(find ${search_path} -maxdepth 1 -name ${libname}*) 2>/dev/null" == "" ]; then
+ ln -s ${TDEDIR}/$(get_libdir)/${libname}* .
+ dirlist="${dirlist} ${dirname/lib\/}"
+ fi
+ popd
+ libname=""
+ fi
+ done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+ echo "SUBDIRS=$dirlis" > "${S}/lib/Makefile.am"
+ echo "SUBDIRS= kformula" > "${S}/filters/Makefile.am"
+ trinity-meta-2_src_prepare
+
+ echo 'all:' > "${S}/Makefile.am"
+ echo 'install:' >> "${S}/Makefile.am"
+ echo '.PHONY: all' >> "${S}/Makefile.am"
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}