summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-libs
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-apps/koffice-libs
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/koffice-libs')
-rw-r--r--trinity-apps/koffice-libs/Manifest1
-rw-r--r--trinity-apps/koffice-libs/koffice-libs-14.0.13.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/trinity-apps/koffice-libs/Manifest b/trinity-apps/koffice-libs/Manifest
index 73586ed3..3643962a 100644
--- a/trinity-apps/koffice-libs/Manifest
+++ b/trinity-apps/koffice-libs/Manifest
@@ -1 +1,2 @@
DIST koffice-trinity-14.0.12.tar.xz 49536824 BLAKE2B 2bece83ab01797fab8d375df7b20b2768da70f9c3441058f457947f3f0569a337fe143d786ce266b27ea093f08f2e1a7d3ce23e4310ecc5126bac2620c1da439 SHA512 4b657747a004a01941845d25f886db66cf89cdb754a3213b17a9fad0e3ec1e9d90dafdc670f31cf6bdd900e3ca50b68cdb8c9b54a5332585d50b3b1cbe8cffea
+DIST koffice-trinity-14.0.13.tar.xz 49541404 BLAKE2B 4501137b87772d2e81f251b3f384cfb5417cdb3507786e392a9fe4e98c18806b9749766e51430702432e33773b379184a48f4790c54d17d86b8b6f191b208e5f SHA512 b82e23e653ee07fccdbcda74dc2727e5e0a4cf889794c1319c6985d2133b63e7f92b84dc5fc1727bfc1217bd39c149db66dd2b2fc1762e415e54933561103fe9
diff --git a/trinity-apps/koffice-libs/koffice-libs-14.0.13.ebuild b/trinity-apps/koffice-libs/koffice-libs-14.0.13.ebuild
new file mode 100644
index 00000000..af39141d
--- /dev/null
+++ b/trinity-apps/koffice-libs/koffice-libs-14.0.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="lib lib/kwmf lib/store lib/kofficecore
+ lib/kofficeui lib/kopainter
+ lib/kopalette lib/kotext lib/kformula
+ lib/koproperty lib/kross filters/olefilters
+ filters/xsltfilter filters/generic_wrapper
+ kounavail servicetypes mimetypes pics
+ templates autocorrect interfaces plugins tools"
+TSM_EXTRACT_ALSO="filters doc kchart"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="Shared KOffice libraries for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ trinity-meta-2_src_prepare
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:${TDEDIR}/$(get_libdir)/pkgconfig
+ myconf=(--with-extra-libs=${TDEDIR}/$(get_libdir)
+ --with-extra-includes=${TDEDIR}/include/arts
+ --disable-scripting)
+
+ trinity-econf ${myconf[@]}
+}