summaryrefslogtreecommitdiffstats
path: root/trinity-apps/konversation/konversation-9999.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
committerChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
commit55d2aaa4eb5201ac97e269fc141e4ee1778379b8 (patch)
tree810ece5e004aa9e97e26a1ad988ed52552175fb6 /trinity-apps/konversation/konversation-9999.ebuild
parent644110a847c5911c2eb04eb53c93031740561efc (diff)
downloadtde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.tar.gz
tde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.zip
Clean up and fix TDE Gentoo overlay.
- Remove old v3.5.13 ebuilds and eclasses - Change repo URL to official TGW - Remove old HAL and traces (TDEHW is used now) - Make split between TDE applications and tdebase consistent - Move TQt into own category (for users filtering dev-qt/ out) - Change to new TQTDIR var - Move away from virtual/pam dependency - Change to use new xorg-proto dependency - Some cosmetic fixes and removal of unneeded files - Remove some now obsolete patches - Change to clean 9999 naming scheme for anything - Add some potential workaround for newer portage versions - Add own README ... thanks to Aggi from IRC for some fixes too. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/konversation/konversation-9999.ebuild')
-rw-r--r--trinity-apps/konversation/konversation-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-apps/konversation/konversation-9999.ebuild b/trinity-apps/konversation/konversation-9999.ebuild
new file mode 100644
index 00000000..c9f07147
--- /dev/null
+++ b/trinity-apps/konversation/konversation-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+TRINITY_LANGS="ar bg ca da de el en_GB es et fi fr gl he hu it ja ka ko pa pt ru sr sr@Latn sv tr zh_CN zh_TW"
+TRINITY_DOC_LANGS="da es et it pt ru sv"
+
+inherit trinity-base
+
+DESCRIPTION="A user friendly IRC Client for Trinity"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="amd64 x86"
+
+need-trinity 14.0.0
+
+SLOT="${TRINITY_VER}"
+IUSE="xscreensaver"
+
+DEPEND="xscreensaver? ( x11-libs/libXScrnSaver )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ )
+
+ trinity-base_src_configure
+}