summaryrefslogtreecommitdiffstats
path: root/trinity-apps/konversation
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-apps/konversation
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/konversation')
-rw-r--r--trinity-apps/konversation/Manifest1
-rw-r--r--trinity-apps/konversation/konversation-14.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/trinity-apps/konversation/Manifest b/trinity-apps/konversation/Manifest
index 83b656ee..5391e11b 100644
--- a/trinity-apps/konversation/Manifest
+++ b/trinity-apps/konversation/Manifest
@@ -1 +1,2 @@
DIST konversation-trinity-14.1.1.tar.xz 4152612 BLAKE2B 3cecd442181d1ed3c8ca3ebd0059cb5e0ecd305fb9a3be7c3041fa93a191e7eab8cfc8b4bb33fcb30c1f48e794e0c175d325048729cee2ba3bbb8c67f04b7cf2 SHA512 f0acba9470b482536fce2d5e101edd9f7d283a506d3df26b73f379c47dafe7c0481a7ddcb8c387706b8c0359028eb913084baa2c3bf071e8909d2ba75d68cbfc
+DIST konversation-trinity-14.1.2.tar.xz 4153116 BLAKE2B e59d233cda13e486e7d54d937bcba17375955c44ae22094702b01e9c123e822f204a21a5315085ed565c9e3fa3a9f0d43c5f9f6bb0fdcd5fc449f29f45d3f7be SHA512 c75d37967c2a2a2a3e718956280f350b505fe04ba5a5b193af2e90980d52c72dea28486f7ed820f9f19a9d088026b1993af9cffc55aeacb19c4966ad8766b79d
diff --git a/trinity-apps/konversation/konversation-14.1.2.ebuild b/trinity-apps/konversation/konversation-14.1.2.ebuild
new file mode 100644
index 00000000..c014e363
--- /dev/null
+++ b/trinity-apps/konversation/konversation-14.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg ca da de el en_GB es et fi fr gl he
+ hu it ja ka ko pa pt ru sr sr@Latn sv tr zh_CN zh_TW"
+
+TRINITY_DOC_LANGS="da es et it pt ru sv"
+
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="A user friendly IRC Client for Trinity"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xscreensaver"
+
+DEPEND="xscreensaver? ( x11-libs/libXScrnSaver )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ )
+ trinity-base-2_src_configure
+}