summaryrefslogtreecommitdiffstats
path: root/trinity-apps/krename
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
commit18d39ed9f062321b596258a9137f10b3e93b71e0 (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/krename
parentcd2192fbe2c90ea734db5bc716740b7dded481b6 (diff)
downloadtde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.tar.gz
tde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/krename')
-rw-r--r--trinity-apps/krename/Manifest1
-rw-r--r--trinity-apps/krename/krename-14.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/krename/Manifest b/trinity-apps/krename/Manifest
index bf636ac8..dee99a4f 100644
--- a/trinity-apps/krename/Manifest
+++ b/trinity-apps/krename/Manifest
@@ -1 +1,2 @@
DIST krename-trinity-14.1.0.tar.xz 188088 BLAKE2B f262ce621323109155aae9518ad69f10a853401c7d127eefd80bcf434bf1e58b5b3901ba44dad1539e3029a5e526b1879ce7bccd6529586abcfd45191014bda6 SHA512 168931d7ca2a5ffe0418e7f7a3f7db383d46ed84741e35d4c5179a9acda9c6f1b9c8cd369bc514bddca124b1c0a3c5b17a26f37253e8fe5b28d646929df8ceb7
+DIST krename-trinity-14.1.1.tar.xz 188140 BLAKE2B 8b825abe1e7dd1ec4efa991e4dbc95bbe3dcbc36df28a17a264f8e8d8791072f3826e112d979d5aef2c374a5c10e0ba0e48a96603940239251eef1db1d66516a SHA512 ce0f09cbc86b5bd00ebadb987e9a708b899d7115f3f3ee16f82948355afe1f14023463245407f3924c5e4da3f0d8b5f21bc7fce6ed801c26da26015eb21b33ce
diff --git a/trinity-apps/krename/krename-14.1.1.ebuild b/trinity-apps/krename/krename-14.1.1.ebuild
new file mode 100644
index 00000000..bd9ade38
--- /dev/null
+++ b/trinity-apps/krename/krename-14.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bs de es fr hu it ja nl
+ pl pt_BR ru sl sv tr zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="A powerful batch file renamer for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst () {
+ echo
+ einfo "Please note that KRename can use TDE's file information plugins as they're"
+ einfo "available, so you might want to install one or more of the following ebuilds:"
+ echo
+ einfo "tdeaddons-tdefile-plugins, tdeadmin-tdefile-plugins,"
+ einfo "tdegraphics-tdefile-plugins, tdemultimedia-tdefile-plugins,"
+ einfo "tdenetwork-tdefile-plugins, tdesdk-tdefile-plugins."
+ echo
+}