summaryrefslogtreecommitdiffstats
path: root/trinity-apps/krename
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/krename
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/krename')
-rw-r--r--trinity-apps/krename/Manifest1
-rw-r--r--trinity-apps/krename/krename-14.0.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/krename/Manifest b/trinity-apps/krename/Manifest
index 11df4161..30153224 100644
--- a/trinity-apps/krename/Manifest
+++ b/trinity-apps/krename/Manifest
@@ -1 +1,2 @@
+DIST krename-trinity-14.0.11.tar.xz 187792 BLAKE2B 014ba7cabe8a3c1f5a729a28daa9c96a58c1545b0f8fc4e45cc48538f1ce22028f68d290b4ed5c9351a002a64a08aeb753cec97deb0402d103a985071a7c71d8 SHA512 e344685f3849b65c453dbc9c7e681f00b7a09a70e06706624e180cf9c7e0a04df228aafadd26d33bf9cef21b4851b66b699a24275fc3b8db7d6a15d685817f0a
DIST krename-trinity-14.0.8.tar.xz 208464 BLAKE2B fcce5c0f362ed8f00215339c14fe5d6b2876f82a14f8f18516954d24c3f424bcc7b23b312cf24248cef398b671b91d795fc930f042d982ba62d1ec9f92b77848 SHA512 7e001b1c1dd0d75e0d33cc8d909a01574b29b64d16990d77f6b9df58f7cfcf78dcb9258806c394a54ef75bafa0c0cd9a3553c2e6076121b12e3b9882df2eb9e4
diff --git a/trinity-apps/krename/krename-14.0.11.ebuild b/trinity-apps/krename/krename-14.0.11.ebuild
new file mode 100644
index 00000000..16742e42
--- /dev/null
+++ b/trinity-apps/krename/krename-14.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bs de es fr hu it ja nl
+ pl pt_BR ru sl sv tr zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="A powerful batch file renamer for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst () {
+ echo
+ einfo "Please note that KRename can use TDE's file information plugins as they're"
+ einfo "available, so you might want to install one or more of the following ebuilds:"
+ echo
+ einfo "tdeaddons-tdefile-plugins, tdeadmin-tdefile-plugins,"
+ einfo "tdegraphics-tdefile-plugins, tdemultimedia-tdefile-plugins,"
+ einfo "tdenetwork-tdefile-plugins, tdesdk-tdefile-plugins."
+ echo
+}