summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kscope
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerSlávek Banko <slavek.banko@axis.cz>2023-10-29 10:05:05 +0100
commit271fc0de62480ffa8a1525e07b833079c96ca6bd (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/kscope
parent8e955e3a507fd32d4b98df0893bb2dfa83b48eb8 (diff)
downloadtde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.tar.gz
tde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
Diffstat (limited to 'trinity-apps/kscope')
-rw-r--r--trinity-apps/kscope/Manifest1
-rw-r--r--trinity-apps/kscope/kscope-14.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/kscope/Manifest b/trinity-apps/kscope/Manifest
index 2e87efcf..8341eac8 100644
--- a/trinity-apps/kscope/Manifest
+++ b/trinity-apps/kscope/Manifest
@@ -1 +1,2 @@
DIST kscope-trinity-14.1.0.tar.xz 1058892 BLAKE2B 5a0d6f4e9ed38cb328e383d3e1c8d11513300d431810b5b3a6810fe2b66c4f7aca51a4c2522642e907fd028542b420b01fe9693d8e9dcbb92c61ba78f527e0e0 SHA512 58a26d3c06b71cb3c711cb0f062818006bac9b427d144c8a2a74503aad04a76367da1616433ae8e33100f39c74d1d339e3d2b6a0e9614a32fbd5772a7005d452
+DIST kscope-trinity-14.1.1.tar.xz 1058828 BLAKE2B 4b43bd947dc48649d01b69663a47ba05383732f73687914df7daa5c25f2c5d6146d11c6dc93701dd75b78b29ded835835bd50b4b7fbcef0502abd6c05ddb648f SHA512 cc572d8d9c2438146ed1fec05f24dbb514b6e475233212afd6198652d57dc4b2002525aebf076cf235a9d88af93b92014f26429d5c912323912f8dd2f5fad528
diff --git a/trinity-apps/kscope/kscope-14.1.1.ebuild b/trinity-apps/kscope/kscope-14.1.1.ebuild
new file mode 100644
index 00000000..e9541a1a
--- /dev/null
+++ b/trinity-apps/kscope/kscope-14.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="TDE front-end to Cscope"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-util/cscope
+ dev-util/ctags
+ ~trinity-base/kate-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}