summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
commit18d39ed9f062321b596258a9137f10b3e93b71e0 (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/kshutdown
parentcd2192fbe2c90ea734db5bc716740b7dded481b6 (diff)
downloadtde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.tar.gz
tde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index 3ae42b38..02f48001 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
DIST kshutdown-trinity-14.1.0.tar.xz 173792 BLAKE2B 78f644c6ab281fcc2ca7350442e33d60035051ce04b5c61a7e48974ad02c0a1cf824cf165562cbbba4468256b2b770c57aa1f1ca96df833c66b390e911e9d281 SHA512 6cda05984d42575c33dd03ad00cf425bf60c5ff4a5b8c7f65eaff8a76beaf627b840bd8f21c3cf6170f2a0cf47cda1abf7127808d8b6ae471c0d8ad9cf085630
+DIST kshutdown-trinity-14.1.1.tar.xz 173868 BLAKE2B 27aeb982cbdce83383f5ffdf08dde60ca683fb8c1cd8693218b61dd1b9701d4d9d2a92593e83ae0b54638f062eba44879fda62c4eb2b7d395131c00654b37aaf SHA512 7dcb474fc1546ac7c274db701142785959af1c72ed17e2ebfe3197edd5e4978640e913356fdc6e09a8d99349c52a5dde6e2c67255b64155566f2412818ae6403
diff --git a/trinity-apps/kshutdown/kshutdown-14.1.1.ebuild b/trinity-apps/kshutdown/kshutdown-14.1.1.ebuild
new file mode 100644
index 00000000..82302ab8
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}