summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-apps/kshutdown
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.1.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index 8f3b52ed..63402779 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
DIST kshutdown-trinity-14.1.1.tar.xz 173868 BLAKE2B 27aeb982cbdce83383f5ffdf08dde60ca683fb8c1cd8693218b61dd1b9701d4d9d2a92593e83ae0b54638f062eba44879fda62c4eb2b7d395131c00654b37aaf SHA512 7dcb474fc1546ac7c274db701142785959af1c72ed17e2ebfe3197edd5e4978640e913356fdc6e09a8d99349c52a5dde6e2c67255b64155566f2412818ae6403
+DIST kshutdown-trinity-14.1.2.tar.xz 169428 BLAKE2B bce5ef6f95d66e5ca4d6d878002f31e04afcf5048e4882bfd26676b8f513e6343794c305beb21aa79e0363e7be83101ccfc60cb142f819e217e8cdcfec68a77a SHA512 b283cedf5d54a28d6082d641fd040b77581ea276a08a7562a859972ec911d47d6f04d2c8710c7126e3321720d5863fa32689c739274a7603427990c63f08e64e
diff --git a/trinity-apps/kshutdown/kshutdown-14.1.2.ebuild b/trinity-apps/kshutdown/kshutdown-14.1.2.ebuild
new file mode 100644
index 00000000..d64c3fa6
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}