summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-apps/kshutdown
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.0.13.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index a7382000..a35e2402 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
DIST kshutdown-trinity-14.0.12.tar.xz 172372 BLAKE2B 57477e99f7601a0c19cb53ff09237fb0e02c870d08a4b1a2ac3b38bd41b3fefccb6f3d902309ee729d89f809387e3d2c82c881f077240ea1c89f89c032445753 SHA512 95ec933fcf0c4c89912bcf95543bfdc968cd188ed533565b44682d4910d4de0f02d25e5442f9f2abda4ef8302335764aabb81cc48d8a4425a1e6c08df4e4e128
+DIST kshutdown-trinity-14.0.13.tar.xz 173852 BLAKE2B cb032f55db1b4cbcc835505190d697827e1fe7f36e7dc13927dbaefcb272fc51f237162e67e0cd66b0b09d3044ce28b417e4f51df252388e92db753fa0ca583e SHA512 9ac3e5bfad23061cb5acbd5d63049709734578650032409a936f13b8fa3112372a15a849711281bc52985df6056b7063238acb20be8b8fb18b02f2d431d8533f
diff --git a/trinity-apps/kshutdown/kshutdown-14.0.13.ebuild b/trinity-apps/kshutdown/kshutdown-14.0.13.ebuild
new file mode 100644
index 00000000..2b148f08
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}