summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/kshutdown
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index 58b5d211..3921b529 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
DIST kshutdown-trinity-14.0.13.tar.xz 173852 BLAKE2B cb032f55db1b4cbcc835505190d697827e1fe7f36e7dc13927dbaefcb272fc51f237162e67e0cd66b0b09d3044ce28b417e4f51df252388e92db753fa0ca583e SHA512 9ac3e5bfad23061cb5acbd5d63049709734578650032409a936f13b8fa3112372a15a849711281bc52985df6056b7063238acb20be8b8fb18b02f2d431d8533f
+DIST kshutdown-trinity-14.1.0.tar.xz 173792 BLAKE2B 78f644c6ab281fcc2ca7350442e33d60035051ce04b5c61a7e48974ad02c0a1cf824cf165562cbbba4468256b2b770c57aa1f1ca96df833c66b390e911e9d281 SHA512 6cda05984d42575c33dd03ad00cf425bf60c5ff4a5b8c7f65eaff8a76beaf627b840bd8f21c3cf6170f2a0cf47cda1abf7127808d8b6ae471c0d8ad9cf085630
diff --git a/trinity-apps/kshutdown/kshutdown-14.1.0.ebuild b/trinity-apps/kshutdown/kshutdown-14.1.0.ebuild
new file mode 100644
index 00000000..82302ab8
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}