summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/mathemagics/mathemagics-14.1.2.ebuild')
-rw-r--r--trinity-apps/mathemagics/mathemagics-14.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild b/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
new file mode 100644
index 00000000..0f01a280
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}