summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-12-06 16:11:21 -0500
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-02-17 16:47:41 +0000
commitf0575f757d3a116ae806b578b37ae4b375a8caf5 (patch)
tree9055d8aa3000cc5d7a90675a7cc27d0d3d54acef /trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild
parent32f776ede66c742cd2dceecb3739b083ac41d92b (diff)
downloadtde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.tar.gz
tde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.zip
14.0.8 ebuilds for everything in trinity-apps that I could make build back in June.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild')
-rw-r--r--trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild b/trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild
new file mode 100644
index 00000000..1c5f0c4a
--- /dev/null
+++ b/trinity-apps/tdepowersave/tdepowersave-14.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs da de el es fi fr hi hu it ja km lt
+ nb nl pa pl pt pt_BR ru sl_SI sv tr uk zh_CN zh_TW"
+
+TRINITY_DOC_LANGS="cs de fi hu nb"
+
+inherit trinity-base-2
+
+DESCRIPTION="A TDE frontend for power management"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+DEPEND+=" x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXtst
+ =dev-libs/dbus-1-tqt-${PV}"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}