summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdepowersave
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerSlávek Banko <slavek.banko@axis.cz>2023-10-29 10:05:05 +0100
commit271fc0de62480ffa8a1525e07b833079c96ca6bd (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/tdepowersave
parent8e955e3a507fd32d4b98df0893bb2dfa83b48eb8 (diff)
downloadtde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.tar.gz
tde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
Diffstat (limited to 'trinity-apps/tdepowersave')
-rw-r--r--trinity-apps/tdepowersave/Manifest1
-rw-r--r--trinity-apps/tdepowersave/tdepowersave-14.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/trinity-apps/tdepowersave/Manifest b/trinity-apps/tdepowersave/Manifest
index dc1bb5da..31057db5 100644
--- a/trinity-apps/tdepowersave/Manifest
+++ b/trinity-apps/tdepowersave/Manifest
@@ -1 +1,2 @@
DIST tdepowersave-trinity-14.1.0.tar.xz 2688316 BLAKE2B 384fb22666ad269244c1fa6fb78acfcfa724229fa1778d4ef0dbe458f5271f8460c644ce745d139577851c33abcb7f568e79916b42d0e8cb5c427a1c3951ecc5 SHA512 80f6cc55474ce11f9986d5171f2c65fead0ab69bef8526f8d713f503569648655dea8fbea051a151056ec305f40047b2bdcc9cc9ca40d91236a20cc5d19ed511
+DIST tdepowersave-trinity-14.1.1.tar.xz 2688092 BLAKE2B f8e2c8f0c54377c16a4e6ce52b0304b5c670da89f384257feef17bf88940a14e4cc18928bf522e5b62c43f4283b82d07b6057188a50d2ba34aa2c1d24fbeb290 SHA512 88716244bdd5964b1b5f19b5c6ea6f3ae9451fe1b11bc2f9f3560810500ae792a890279d27d3f29e184c537b95bf60de46324f0a69aae670ad0ca0112daf57a8
diff --git a/trinity-apps/tdepowersave/tdepowersave-14.1.1.ebuild b/trinity-apps/tdepowersave/tdepowersave-14.1.1.ebuild
new file mode 100644
index 00000000..22701e5f
--- /dev/null
+++ b/trinity-apps/tdepowersave/tdepowersave-14.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2019-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs da de el es fi fr hi hu it ja km lt
+ nb nl pa pl pt pt_BR ru sl_SI sv tr uk zh_CN zh_TW"
+
+TRINITY_DOC_LANGS="cs de fi hu nb"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A TDE frontend for power management"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}