summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesudo/tdesudo-9999.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-29 17:33:44 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-30 12:08:23 +0000
commit32ce5d40c1b02e8bc5c2a1c0ae0d81b8682ecfff (patch)
tree69f4f5a557fd8b808aaf66ad595eb0c658a67e26 /trinity-apps/tdesudo/tdesudo-9999.ebuild
parentcd532a3a82720dd366daa31932daf9f2d39cbcea (diff)
downloadtde-packaging-gentoo-32ce5d40c1b02e8bc5c2a1c0ae0d81b8682ecfff.tar.gz
tde-packaging-gentoo-32ce5d40c1b02e8bc5c2a1c0ae0d81b8682ecfff.zip
Live ebuilds: Add preliminary `TDESudo` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/tdesudo/tdesudo-9999.ebuild')
-rw-r--r--trinity-apps/tdesudo/tdesudo-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/tdesudo/tdesudo-9999.ebuild b/trinity-apps/tdesudo/tdesudo-9999.ebuild
new file mode 100644
index 00000000..d9f60685
--- /dev/null
+++ b/trinity-apps/tdesudo/tdesudo-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de fr"
+
+inherit trinity-base-2
+
+DESCRIPTION="Sudo frontend for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+RDEPEND+=" app-admin/sudo"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}