summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-apps/tdesvn
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/tdesvn')
-rw-r--r--trinity-apps/tdesvn/Manifest1
-rw-r--r--trinity-apps/tdesvn/tdesvn-14.1.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/tdesvn/Manifest b/trinity-apps/tdesvn/Manifest
index b4f3e26f..2a8d47bf 100644
--- a/trinity-apps/tdesvn/Manifest
+++ b/trinity-apps/tdesvn/Manifest
@@ -1 +1,2 @@
DIST tdesvn-trinity-14.1.1.tar.xz 1160424 BLAKE2B e4a28a3e856869a9a01bf9cbf51a9e016c7a2b1f4f0bee10a29f23e47c2eb41a0210419aea5deabb7d1aacab742bbabea3a82d8b076c8312893c21817914c78a SHA512 59db1318907179135622065f437aba5e202657ff1a2f315872d2d84e5d96c2f452655c8073ae5c36e68877b5a5905dccb35b6ceebab9ab15df940b73917c9e1c
+DIST tdesvn-trinity-14.1.2.tar.xz 1153712 BLAKE2B 5419be9ecc3bec7d798edf8c0b90d6702a72291c674cf842dc23891cd111a3770fe415b49565de2b8f1263b0f8184b1e7958aa60c994eddccbc4bc2a2377cab2 SHA512 fb8364249152dc44589282f7b3e4c06bdcaeab6285429f7e1b08f60592a6fd82ac66c1150866bc122fcee858e59c19b2ce3ee95f2cb28cb855209da6a6752fcf
diff --git a/trinity-apps/tdesvn/tdesvn-14.1.2.ebuild b/trinity-apps/tdesvn/tdesvn-14.1.2.ebuild
new file mode 100644
index 00000000..23fd36bc
--- /dev/null
+++ b/trinity-apps/tdesvn/tdesvn-14.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="Subversion client with tight TDE integration"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="test"
+
+RESTRICT+=" !test? ( test )"
+
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ trinity-base-2_src_configure
+}