summaryrefslogtreecommitdiffstats
path: root/trinity-apps/twin-style-machbunt
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa /trinity-apps/twin-style-machbunt
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.tar.gz
tde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/twin-style-machbunt')
-rw-r--r--trinity-apps/twin-style-machbunt/Manifest1
-rw-r--r--trinity-apps/twin-style-machbunt/metadata.xml8
-rw-r--r--trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild31
-rw-r--r--trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild31
4 files changed, 71 insertions, 0 deletions
diff --git a/trinity-apps/twin-style-machbunt/Manifest b/trinity-apps/twin-style-machbunt/Manifest
new file mode 100644
index 00000000..c235c00c
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/Manifest
@@ -0,0 +1 @@
+DIST twin-style-machbunt-trinity-14.1.0.tar.xz 25340 BLAKE2B 86de62cc0257881b9f006e93e5dce8ade38231a89ebd0972b843f5360acc55c477019ddcec3440f1374b95d8d0ac61b1d9c58d5b8fecf567b0877bf18e7828b2 SHA512 26aba2882e5b81cb6a14e6f4f2c6fbbcb092040a92a86861bc0dbec86c0a1dc03f62bd1d316337b511fd0f4ccaaeb834b3552f6bb32c9ca2c54cbc6c1e7df1a3
diff --git a/trinity-apps/twin-style-machbunt/metadata.xml b/trinity-apps/twin-style-machbunt/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild b/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild
new file mode 100644
index 00000000..42c89967
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme - machbunt"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild b/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild
new file mode 100644
index 00000000..bb75ad60
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme - machbunt"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}