summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-28 14:01:37 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-29 11:41:36 +0000
commitb38bf581cbb0aac8a123f6637a9ab1e7e2c56edf (patch)
tree4612f69df2aa0ccd73b858f386e09e85a479a237 /trinity-apps
parent56104efb45f33a9a8bb82dec756b7020cf1f9b7f (diff)
downloadtde-packaging-gentoo-b38bf581cbb0aac8a123f6637a9ab1e7e2c56edf.tar.gz
tde-packaging-gentoo-b38bf581cbb0aac8a123f6637a9ab1e7e2c56edf.zip
Live ebuilds: Add preliminary `Kooldock` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/kooldock/kooldock-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-apps/kooldock/kooldock-9999.ebuild b/trinity-apps/kooldock/kooldock-9999.ebuild
new file mode 100644
index 00000000..19b16524
--- /dev/null
+++ b/trinity-apps/kooldock/kooldock-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="cs de es fr it nl pl sv"
+
+inherit trinity-base-2
+
+DESCRIPTION="A dock for TDE, which attemps to resemble the Mac OSX dock"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}