summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-29 17:21:37 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-30 12:07:40 +0000
commitcd532a3a82720dd366daa31932daf9f2d39cbcea (patch)
treea10aa540b6dfc19977a565bf5458a71325864630 /trinity-apps
parent8271e6336e6748a5b9819871d0734c2f632343b8 (diff)
downloadtde-packaging-gentoo-cd532a3a82720dd366daa31932daf9f2d39cbcea.tar.gz
tde-packaging-gentoo-cd532a3a82720dd366daa31932daf9f2d39cbcea.zip
Live ebuilds: Add preliminary `KVKBD` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/kvkbd/kvkbd-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/trinity-apps/kvkbd/kvkbd-9999.ebuild b/trinity-apps/kvkbd/kvkbd-9999.ebuild
new file mode 100644
index 00000000..52786820
--- /dev/null
+++ b/trinity-apps/kvkbd/kvkbd-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="A virtual keyboard for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+DEPEND+=" x11-libs/libXtst"
+RDEPEND=+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}