summaryrefslogtreecommitdiffstats
path: root/trinity-base/arts
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/arts
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/arts')
-rw-r--r--trinity-base/arts/Manifest1
-rw-r--r--trinity-base/arts/arts-14.1.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/trinity-base/arts/Manifest b/trinity-base/arts/Manifest
index b8c6775c..91366434 100644
--- a/trinity-base/arts/Manifest
+++ b/trinity-base/arts/Manifest
@@ -1 +1,2 @@
DIST arts-trinity-14.0.13.tar.xz 663772 BLAKE2B 63ae994c8757a764ff430885d1bdf0d998537b6bf40f5c86b21a4de3f6069059f494d015499d9dab5296db9181a1d0aeb1173a375573c7250a5b7ea59386d4cc SHA512 82c1b8a62ed4546eb00ff795e28a0b51eb395fe53a1e2ae93e1ff8bd23caa8f53dce776accfcef5ced3d4fbb8264cea7acc947ecb183236c0bbe4e5e59eeca5c
+DIST arts-trinity-14.1.0.tar.xz 662148 BLAKE2B e06639434352a8d6d32b63f76c1b5bdf7e29f42bee1c1acd92d5024eb4afb24762c445e206c487c40dc9f5cfaa4a00ca1126aa16463c293542be1f9e0034268a SHA512 c9bb8deb916c5b523f14693fbef5dad0c107480a503c53f92007460ab125bcf94bd7397438085ed25dae56cdd7543b5c4f080e30842e4a515e0bc48618395769
diff --git a/trinity-base/arts/arts-14.1.0.ebuild b/trinity-base/arts/arts-14.1.0.ebuild
new file mode 100644
index 00000000..489a99ce
--- /dev/null
+++ b/trinity-base/arts/arts-14.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="arts"
+inherit trinity-base-2
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+IUSE="alsa -artswrappersuid jack mp3 vorbis"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+SLOT="14"
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+ dev-libs/glib
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( virtual/jack )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIOFILE=ON
+ -DWITH_MAD="$(usex mp3)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_VORBIS="$(usex vorbis)"
+ -DWITH_JACK="$(usex jack)"
+ -DWITH_ESOUND=OFF
+ -DWITH_SNDIO=OFF
+ )
+
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ trinity-base-2_src_install
+
+ # Used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${TDEDIR}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${TDEDIR}/bin/artswrapper to let artsd use realtime"
+ elog "priority and so avoid possible skips in sound. However, on untrusted systems"
+ elog "this creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See Gentoo bug #7883."
+ elog "Or, you can set the artswrappersuid USE flag to make the ebuild do this."
+ fi
+}