summaryrefslogtreecommitdiffstats
path: root/trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 15:11:56 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 10:10:21 +0100
commit9b3eddb24c48f766b7d8b09e964b9c321a976e1a (patch)
treeee6b1818d83b16cddda46e819c5d1ae245f8ddd3 /trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild
parent18b54c6e19558c3dcfdf6d41bd64bd6850a3d924 (diff)
downloadtde-packaging-gentoo-9b3eddb24c48f766b7d8b09e964b9c321a976e1a.tar.gz
tde-packaging-gentoo-9b3eddb24c48f766b7d8b09e964b9c321a976e1a.zip
14.0.7 and 14.0.8 ebuilds for roughly 50% of tdepim (see the tdepim-meta ebuild for what is missing and why)
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild')
-rw-r--r--trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild b/trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild
new file mode 100644
index 00000000..f0874eef
--- /dev/null
+++ b/trinity-base/kaddressbook/kaddressbook-14.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta-2
+
+DESCRIPTION="The Trinity Address Book"
+KEYWORDS="~amd64 ~x86"
+IUSE+=" gnokii"
+
+COMMON_DEPEND="~trinity-base/libtdepim-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ gnokii? ( app-mobilephone/gnokii )"
+
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+TSM_EXTRACT_ALSO="certmanager/lib/
+ libtdepim/
+ libtdenetwork/
+ libkcal/
+ libemailfunctions/"
+
+src_configure () {
+ mycmakeargs=(
+ -DWITH_GNOKII="$(usex gnokii)"
+ )
+ trinity-meta-2_src_configure
+}