summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
commit18d39ed9f062321b596258a9137f10b3e93b71e0 (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-base/kdesktop
parentcd2192fbe2c90ea734db5bc716740b7dded481b6 (diff)
downloadtde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.tar.gz
tde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kdesktop')
-rw-r--r--trinity-base/kdesktop/Manifest1
-rw-r--r--trinity-base/kdesktop/kdesktop-14.1.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/trinity-base/kdesktop/Manifest b/trinity-base/kdesktop/Manifest
index 0c86c08c..946d63c0 100644
--- a/trinity-base/kdesktop/Manifest
+++ b/trinity-base/kdesktop/Manifest
@@ -1 +1,2 @@
DIST tdebase-trinity-14.1.0.tar.xz 30722632 BLAKE2B 1f4b87be37730aaa93fc579c130d7af7c408d20512ff8642d8313abaa7ccf6a012c8b52c595641e8ff820f709d68471224f2ceb1f898769b36e386345924b948 SHA512 8fcbb5d4bbaefc9acafa5d1926d6f22b1c087a7af63f0d9e2438c95730e82e6d6e9555afdf336bd01c296adedef5665c571d00c6738d071ed069243d47f30674
+DIST tdebase-trinity-14.1.1.tar.xz 30746484 BLAKE2B 4d2fdd9e3f5007c7482e938badad381a3e314b458b262dd346c05c91a9a4b974d8f1244152b833a34f7edad246bd4a8af0e054279a1556cebac6319a1a011a09 SHA512 d733f20719a0c9a949540e95f4d60fe03e096efbd7ac54187c5ee9b9f9b644318ee2dd9c8fd0d2e6eee660f7a7ad827e66bc06fb9a36c9e56e3ae16bdd47910c
diff --git a/trinity-base/kdesktop/kdesktop-14.1.1.ebuild b/trinity-base/kdesktop/kdesktop-14.1.1.ebuild
new file mode 100644
index 00000000..a234cc7f
--- /dev/null
+++ b/trinity-base/kdesktop/kdesktop-14.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kcheckpass/ translations/ FindXscreensaver.cmake"
+inherit trinity-meta-2
+
+DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="pam xscreensaver hwlib"
+
+COMMON_DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/libkonq-${PV}
+ x11-libs/libXrender
+ x11-libs/libXcursor
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+DEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
+RDEPEND="${COMMON_DEPEND}
+ ~trinity-base/kcheckpass-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/konqueror-${PV}
+ pam? ( trinity-base/tdebase-pam )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_XRENDER=ON
+ -DWITH_PAM="$(usex pam)"
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ -DTDESCREENSAVER_PAM_SERVICE=tde
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+ trinity-meta-2_src_configure
+}