summaryrefslogtreecommitdiffstats
path: root/trinity-base/keduca/keduca-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/keduca/keduca-14.1.2.ebuild
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/keduca/keduca-14.1.2.ebuild')
-rw-r--r--trinity-base/keduca/keduca-14.1.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/trinity-base/keduca/keduca-14.1.2.ebuild b/trinity-base/keduca/keduca-14.1.2.ebuild
new file mode 100644
index 00000000..64fc0094
--- /dev/null
+++ b/trinity-base/keduca/keduca-14.1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdeedu"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+TRINITY_NEED_ARTS="optional"
+inherit trinity-meta-2
+
+DESCRIPTION="Interactive form-based tests for Trinity"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_prepare() {
+ sed -i -e '/add_subdirectory( applnk )/d' \
+ -e '/add_subdirectory( libtdeedu )/d' "${S}/CMakeLists.txt" || die
+ trinity-meta-2_src_prepare
+}