summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/kicker-3.5.13.2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/kicker/kicker-3.5.13.2.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/kicker/kicker-3.5.13.2.ebuild')
-rw-r--r--trinity-base/kicker/kicker-3.5.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-base/kicker/kicker-3.5.13.2.ebuild b/trinity-base/kicker/kicker-3.5.13.2.ebuild
new file mode 100644
index 00000000..3d5ae385
--- /dev/null
+++ b/trinity-base/kicker/kicker-3.5.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal xcomposite"
+
+DEPEND=">=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/kdebase-data-${PV}:${SLOT}
+ xcomposite? ( x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ trinity-base/kmenuedit:${SLOT}"
+
+PATCHES=( "$FILESDIR/${PN}-3.5.13.2-include-dbus.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xcomposite XFIXES)
+ $(cmake-utils_use_with xcomposite XRENDER)
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ $(cmake-utils_use_with hal HAL)
+ )
+
+ trinity-meta_src_configure
+}