summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmail/kmail-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/kmail/kmail-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kmail/kmail-14.1.0.ebuild')
-rw-r--r--trinity-base/kmail/kmail-14.1.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/trinity-base/kmail/kmail-14.1.0.ebuild b/trinity-base/kmail/kmail-14.1.0.ebuild
new file mode 100644
index 00000000..3ed87367
--- /dev/null
+++ b/trinity-base/kmail/kmail-14.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/kcalendariface.h
+ korganizer/korganizeriface.h
+ libkpimidentities/
+ libkpgp/
+ libkmime/
+ libksieve/
+ kmail/
+ translations/"
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+DEPEND="
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/ktnef-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/libkmime-${PV}
+ ~trinity-base/libkpgp-${PV}
+ ~trinity-base/libkpimidentities-${PV}
+ ~trinity-base/libksieve-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ ~trinity-base/libtdepim-${PV}
+ ~trinity-base/mimelib-${PV}
+"
+RDEPEND="${DEPEND}
+ ~trinity-base/tdebase-tdeioslaves-${PV}
+ crypt? ( app-crypt/pinentry )
+ imap? ( ~trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )
+ mbox? ( ~trinity-base/tdepim-tdeioslaves-${PV} )
+ sasl? ( ~trinity-base/tdebase-tdeioslaves-${PV}[sasl=] )
+"
+
+src_install() {
+ trinity-meta-2_src_install
+ insinto "${TDEDIR}/include/kmail"
+ doins "${BUILD_DIR}/kmail"/*.h
+}
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+}