summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmail
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 15:11:56 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 10:10:21 +0100
commit9b3eddb24c48f766b7d8b09e964b9c321a976e1a (patch)
treeee6b1818d83b16cddda46e819c5d1ae245f8ddd3 /trinity-base/kmail
parent18b54c6e19558c3dcfdf6d41bd64bd6850a3d924 (diff)
downloadtde-packaging-gentoo-9b3eddb24c48f766b7d8b09e964b9c321a976e1a.tar.gz
tde-packaging-gentoo-9b3eddb24c48f766b7d8b09e964b9c321a976e1a.zip
14.0.7 and 14.0.8 ebuilds for roughly 50% of tdepim (see the tdepim-meta ebuild for what is missing and why)
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/kmail')
-rw-r--r--trinity-base/kmail/Manifest2
-rw-r--r--trinity-base/kmail/kmail-14.0.7.ebuild59
-rw-r--r--trinity-base/kmail/kmail-14.0.8.ebuild59
3 files changed, 120 insertions, 0 deletions
diff --git a/trinity-base/kmail/Manifest b/trinity-base/kmail/Manifest
new file mode 100644
index 00000000..7add9d33
--- /dev/null
+++ b/trinity-base/kmail/Manifest
@@ -0,0 +1,2 @@
+DIST tdepim-trinity-14.0.7.tar.xz 9367460 BLAKE2B cbb4a16cd18dcfbd09dffd829b086c02af36863e57b72af8496c28870b21cbfe2525809f0116e38ccbfd03ec0216617c240c46248f63fb35c993fe632c434048 SHA512 ebedf72b1454c22dfa60608ce83083e3e366758160b42dbaf881f754a0d95ea3cef9b5bbfe1849f3ef6ecfc2fb9635056cc8595d3f7e910e1c91394aceb2c76d
+DIST tdepim-trinity-14.0.8.tar.xz 9357184 BLAKE2B d5e489faa5a2e7db41dc1f076280e8115fd5c7cfd136c65088418ef1e2f2e5ddb0eaf013818acabeb96d7b4ed72ae4b749b1872066c6f804fd4292aa7c0d1c5f SHA512 f9f4d49d5ec02f1e2f472d4dff5b1f326ffa657e3e33f83a3d396ae729c978afcf2ee6256098f4bf0f958a17838a50633a27cbb11e4d177f19b306b72bb5db62
diff --git a/trinity-base/kmail/kmail-14.0.7.ebuild b/trinity-base/kmail/kmail-14.0.7.ebuild
new file mode 100644
index 00000000..dd8487a4
--- /dev/null
+++ b/trinity-base/kmail/kmail-14.0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+COMMON_DEPEND="
+ ~trinity-base/libtdepim-${PV}
+ ~trinity-base/mimelib-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ ~trinity-base/ktnef-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/libkmime-${PV}
+ ~trinity-base/libkpgp-${PV}
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/libkpimidentities-${PV}
+ ~trinity-base/libksieve-${PV}"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/pinentry )
+ ~trinity-base/tdebase-tdeioslaves-${PV}
+ mbox? ( ~trinity-base/tdepim-tdeioslaves-${PV} )
+ imap? ( ~trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )"
+
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/korganizerinterface.h
+ korganizer/kcalendarinterface.h
+ korganizer/kcalendariface.h
+ korganizer/korganizeriface.h
+ libkpgp/
+ libkmime/
+ libksieve/
+ libkpimidentities/
+ kmail/"
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+} \ No newline at end of file
diff --git a/trinity-base/kmail/kmail-14.0.8.ebuild b/trinity-base/kmail/kmail-14.0.8.ebuild
new file mode 100644
index 00000000..dd8487a4
--- /dev/null
+++ b/trinity-base/kmail/kmail-14.0.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+COMMON_DEPEND="
+ ~trinity-base/libtdepim-${PV}
+ ~trinity-base/mimelib-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ ~trinity-base/ktnef-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/libkmime-${PV}
+ ~trinity-base/libkpgp-${PV}
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/libkpimidentities-${PV}
+ ~trinity-base/libksieve-${PV}"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/pinentry )
+ ~trinity-base/tdebase-tdeioslaves-${PV}
+ mbox? ( ~trinity-base/tdepim-tdeioslaves-${PV} )
+ imap? ( ~trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )"
+
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/korganizerinterface.h
+ korganizer/kcalendarinterface.h
+ korganizer/kcalendariface.h
+ korganizer/korganizeriface.h
+ libkpgp/
+ libkmime/
+ libksieve/
+ libkpimidentities/
+ kmail/"
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+} \ No newline at end of file