summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmail
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/kmail
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kmail')
-rw-r--r--trinity-base/kmail/Manifest1
-rw-r--r--trinity-base/kmail/kmail-14.0.11.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/trinity-base/kmail/Manifest b/trinity-base/kmail/Manifest
index 6cfcf9e7..cd1e41b1 100644
--- a/trinity-base/kmail/Manifest
+++ b/trinity-base/kmail/Manifest
@@ -1 +1,2 @@
+DIST tdepim-trinity-14.0.11.tar.xz 9387536 BLAKE2B 1d1874fe2bc962214d2a05c87bd75536280a08feb0ea5aaeee843dff145862fa8d43c6c6c29e7a2b304cc25748dc30ba1fb42336e0ed09322b5969a2b3d4c7a5 SHA512 a7f6e2f6f0080cd745d63fec7c573f0b6e8634470cf60985ac2c0d830fc0003c791585730a95e5ca242e3d9d037765be530606b3642a4764536bd07be262be74
DIST tdepim-trinity-14.0.8.tar.xz 9357184 BLAKE2B d5e489faa5a2e7db41dc1f076280e8115fd5c7cfd136c65088418ef1e2f2e5ddb0eaf013818acabeb96d7b4ed72ae4b749b1872066c6f804fd4292aa7c0d1c5f SHA512 f9f4d49d5ec02f1e2f472d4dff5b1f326ffa657e3e33f83a3d396ae729c978afcf2ee6256098f4bf0f958a17838a50633a27cbb11e4d177f19b306b72bb5db62
diff --git a/trinity-base/kmail/kmail-14.0.11.ebuild b/trinity-base/kmail/kmail-14.0.11.ebuild
new file mode 100644
index 00000000..c68e883d
--- /dev/null
+++ b/trinity-base/kmail/kmail-14.0.11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/kcalendariface.h
+ korganizer/korganizeriface.h
+ libkpimidentities/
+ libkpgp/
+ libkmime/
+ libksieve/
+ kmail/
+ translations/"
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+DEPEND="
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/ktnef-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/libkmime-${PV}
+ ~trinity-base/libkpgp-${PV}
+ ~trinity-base/libkpimidentities-${PV}
+ ~trinity-base/libksieve-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ ~trinity-base/libtdepim-${PV}
+ ~trinity-base/mimelib-${PV}
+"
+RDEPEND="${DEPEND}
+ ~trinity-base/tdebase-tdeioslaves-${PV}
+ crypt? ( app-crypt/pinentry )
+ imap? ( ~trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )
+ mbox? ( ~trinity-base/tdepim-tdeioslaves-${PV} )
+ sasl? ( ~trinity-base/tdebase-tdeioslaves-${PV}[sasl=] )
+"
+
+src_install() {
+ trinity-meta-2_src_install
+ insinto "${TDEDIR}/include/kmail"
+ doins "${BUILD_DIR}/kmail"/*.h
+}
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+}