summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmilo
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
committerChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
commit55d2aaa4eb5201ac97e269fc141e4ee1778379b8 (patch)
tree810ece5e004aa9e97e26a1ad988ed52552175fb6 /trinity-base/kmilo
parent644110a847c5911c2eb04eb53c93031740561efc (diff)
downloadtde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.tar.gz
tde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.zip
Clean up and fix TDE Gentoo overlay.
- Remove old v3.5.13 ebuilds and eclasses - Change repo URL to official TGW - Remove old HAL and traces (TDEHW is used now) - Make split between TDE applications and tdebase consistent - Move TQt into own category (for users filtering dev-qt/ out) - Change to new TQTDIR var - Move away from virtual/pam dependency - Change to use new xorg-proto dependency - Some cosmetic fixes and removal of unneeded files - Remove some now obsolete patches - Change to clean 9999 naming scheme for anything - Add some potential workaround for newer portage versions - Add own README ... thanks to Aggi from IRC for some fixes too. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/kmilo')
-rw-r--r--trinity-base/kmilo/Manifest2
-rw-r--r--trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch67
-rw-r--r--trinity-base/kmilo/kmilo-3.5.13.1.ebuild30
-rw-r--r--trinity-base/kmilo/kmilo-3.5.13.2.ebuild28
4 files changed, 0 insertions, 127 deletions
diff --git a/trinity-base/kmilo/Manifest b/trinity-base/kmilo/Manifest
deleted file mode 100644
index c59ac62b..00000000
--- a/trinity-base/kmilo/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST kdeutils-3.5.13.1.tar.gz 2829393 SHA256 3e7ab07fe1bb3e7be7ac3a3796366c88d3b79a58af911546e2c65e32363db527 SHA512 48733e472d0f5da85ef8a32ed6db7fa5e61f0682e49842439e6ea38a1e407059bb35efffe41fc6ed1a718511fd5b2b2c8222d816a23500a4dcbca17461f9a3bd WHIRLPOOL 1488e0c44f60b4d5e397dd2cf93de048eae1b915d4b2b7b1cf27768946f5aae3b5bcc3971ee28b5fa6a57a0b94cca6db0866138b69ad74f1f7bb97cdaaebdbe2
-DIST kdeutils-trinity-3.5.13.2.tar.xz 2259232 SHA256 b2999b9ef39bb2f269b84fdf34a814b5a5599aae7d05538d0bf680c18fb334fa SHA512 f501aa4b61bf440e873eec96f09c0c24ad780db2f9f14b884001c04c04aafccb5afb2b492dcf4fc640f3ec35d86aa419d67936122648a986662cd7b7f4f8a2d8 WHIRLPOOL 49296006875250212f0fdeb0c90c4f69cf0aa7cfd38415e2f7b50bdf81754de64562df2400f4932a502adbe84b58be34cae6c029d68cc62d0e91de5158513239
diff --git a/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch b/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch
deleted file mode 100644
index f5830b6b..00000000
--- a/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
-index 14828bc..2766533 100644
---- a/ConfigureChecks.cmake
-+++ b/ConfigureChecks.cmake
-@@ -117,24 +117,21 @@ endif( )
-
- ##### kmilo #####################################
-
--if ( BUILD_KMILO )
-+if( BUILD_KMILO )
- # FIXME: If anybody will ever compile trinity for POWERPC and especialy for
--# POWERBOOK he should test those checks and modules
-- if( WITH_POWERBOOK )
-+# POWERBOOK he or she should test workability of those modules
-+ if( WITH_POWERBOOK OR WITH_POWERBOOK2 )
-+ check_library_exists( "pbb" "init_libpbb" "" HAVE_PBBIPC_LIBRARY )
- check_include_file( "pbbipc.h" HAVE_PBBIPC_H )
-- if( NOT HAVE_PBBIPC_H )
-- tde_message_fatal( "pbbipc.h header is required, but was not found on your system" )
-- endif( NOT HAVE_PBBIPC_H )
-- endif( WITH_POWERBOOK )
--
-- if( WITH_POWERBOOK2 )
- check_include_file( "pbb.h" HAVE_PBB_H )
-- if( NOT HAVE_PBB_H )
-- tde_message_fatal( "pbb.h header is required, but was not found on your system" )
-- endif( NOT HAVE_PBB_H )
-- endif( WITH_POWERBOOK2 )
--
--endif (BUILD_KMILO)
-+ if( HAVE_PBBIPC_LIBRARY AND ( ( WITH_POWERBOOK AND HAVE_PBBIPC_H ) OR
-+ ( WITH_POWERBOOK2 AND HAVE_PBB_H ) ) )
-+ set( PBB_LIBRARY pbb CACHE INTERNAL "" )
-+ else()
-+ tde_message_fatal( "suitable pbbuttonosd is required, but was not found on your system" )
-+ endif()
-+ endif( WITH_POWERBOOK OR WITH_POWERBOOK2 )
-+endif( BUILD_KMILO )
-
-
- ##### ksim ######################################
-diff --git a/kmilo/powerbook/CMakeLists.txt b/kmilo/powerbook/CMakeLists.txt
-index 461d2d2..bb98b70 100644
---- a/kmilo/powerbook/CMakeLists.txt
-+++ b/kmilo/powerbook/CMakeLists.txt
-@@ -28,7 +28,7 @@ link_directories(
-
- tde_add_kpart( kmilo_powerbook AUTOMOC
- SOURCES pb_monitor.cpp
-- LINK kio-shared kmilo-shared
-+ LINK kio-shared kmilo-shared ${PBB_LIBRARY}
- DESTINATION ${PLUGIN_INSTALL_DIR}
- )
-
-diff --git a/kmilo/powerbook2/CMakeLists.txt b/kmilo/powerbook2/CMakeLists.txt
-index 461d2d2..bb98b70 100644
---- a/kmilo/powerbook2/CMakeLists.txt
-+++ b/kmilo/powerbook2/CMakeLists.txt
-@@ -28,7 +28,7 @@ link_directories(
-
- tde_add_kpart( kmilo_powerbook AUTOMOC
- SOURCES pb_monitor.cpp
-- LINK kio-shared kmilo-shared
-+ LINK kio-shared kmilo-shared ${PBB_LIBRARY}
- DESTINATION ${PLUGIN_INSTALL_DIR}
- )
-
diff --git a/trinity-base/kmilo/kmilo-3.5.13.1.ebuild b/trinity-base/kmilo/kmilo-3.5.13.1.ebuild
deleted file mode 100644
index 64fd8d86..00000000
--- a/trinity-base/kmilo/kmilo-3.5.13.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-TRINITY_MODULE_NAME="kdeutils"
-
-inherit trinity-meta
-
-DESCRIPTION="kded module supports some hardware input devices, such as special keys"
-KEYWORDS="x86 amd64"
-IUSE="asus-laptop dell-laptop powerbook-laptop thinkpad-laptop vaio-laptop lm_sensors"
-
-DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
-RDEPEND="${DEPEND}
- lm_sensors? ( sys-apps/lm_sensors )"
-
-PATCHES=( "$FILESDIR/${TRINITY_MODULE_NAME}-${PV}-${PN}-fix-powerbook.patch" )
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with asus-laptop ASUS)
- $(cmake-utils_use_with dell-laptop I8K)
- $(cmake-utils_use_with powerbook-laptop POWERBOOK2)
- $(cmake-utils_use_with thinkpad-laptop THINKPAD)
- $(cmake-utils_use_with vaio-laptop VAIO)
- $(cmake-utils_use_with lm_sensors SENSORS)
- )
-
- trinity-meta_src_configure
-}
diff --git a/trinity-base/kmilo/kmilo-3.5.13.2.ebuild b/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
deleted file mode 100644
index 99b580f8..00000000
--- a/trinity-base/kmilo/kmilo-3.5.13.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-TRINITY_MODULE_NAME="kdeutils"
-
-inherit trinity-meta
-
-DESCRIPTION="kded module supports some hardware input devices, such as special keys"
-KEYWORDS="~x86 ~amd64"
-IUSE="asus-laptop dell-laptop powerbook-laptop thinkpad-laptop vaio-laptop lm_sensors"
-
-DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
-RDEPEND="${DEPEND}
- lm_sensors? ( sys-apps/lm_sensors )"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with asus-laptop ASUS)
- $(cmake-utils_use_with dell-laptop I8K)
- $(cmake-utils_use_with powerbook-laptop POWERBOOK2)
- $(cmake-utils_use_with thinkpad-laptop THINKPAD)
- $(cmake-utils_use_with vaio-laptop VAIO)
- $(cmake-utils_use_with lm_sensors SENSORS)
- )
-
- trinity-meta_src_configure
-}