summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmix/kmix-14.0.8.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 16:16:34 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 14:22:25 +0100
commit58de8263fcaa4acba0df369a017c4a29cacfd99f (patch)
treee3dcd318dc5264036454a9bf103474870242f69c /trinity-base/kmix/kmix-14.0.8.ebuild
parent9b3eddb24c48f766b7d8b09e964b9c321a976e1a (diff)
downloadtde-packaging-gentoo-58de8263fcaa4acba0df369a017c4a29cacfd99f.tar.gz
tde-packaging-gentoo-58de8263fcaa4acba0df369a017c4a29cacfd99f.zip
14.0.7 and 14.0.8 ebuilds for roughly 40% of tdemultimedia (see the tdemultimedia-meta ebuild for what is missing and why). Note that these have been test-built in minimalist configurations only and additional TSM_EXTRACT_ALSO entries may be needed. Also, some deps that used to be optional aren't anymore.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/kmix/kmix-14.0.8.ebuild')
-rw-r--r--trinity-base/kmix/kmix-14.0.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/kmix/kmix-14.0.8.ebuild b/trinity-base/kmix/kmix-14.0.8.ebuild
new file mode 100644
index 00000000..c9e9a621
--- /dev/null
+++ b/trinity-base/kmix/kmix-14.0.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdemultimedia"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity mixer GUI"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_ALSA="$(usex alsa)"
+ )
+
+ trinity-meta-2_src_configure
+}