summaryrefslogtreecommitdiffstats
path: root/trinity-base/kscd/kscd-14.0.8.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-27 17:16:51 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 14:22:25 +0100
commit8aced284ba6d730993791293cbd667c1f3bc6ce5 (patch)
tree6747c0ae97ca506087e6bcd19aa2ee1282a428ca /trinity-base/kscd/kscd-14.0.8.ebuild
parent58de8263fcaa4acba0df369a017c4a29cacfd99f (diff)
downloadtde-packaging-gentoo-8aced284ba6d730993791293cbd667c1f3bc6ce5.tar.gz
tde-packaging-gentoo-8aced284ba6d730993791293cbd667c1f3bc6ce5.zip
Ebuilds for media-libs/akode, krec, kscd, libkcddb, tdemultimedia-doc, with corresponding updates to tdemultimedia-meta. Warning: krec and kscd needed some hacky workarounds to build and install.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/kscd/kscd-14.0.8.ebuild')
-rw-r--r--trinity-base/kscd/kscd-14.0.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/trinity-base/kscd/kscd-14.0.8.ebuild b/trinity-base/kscd/kscd-14.0.8.ebuild
new file mode 100644
index 00000000..15a9b892
--- /dev/null
+++ b/trinity-base/kscd/kscd-14.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdemultimedia"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity mixer GUI"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXext
+ ~trinity-base/libkcddb-${PV}"
+
+TSM_EXTRACT_ALSO="libkcddb/"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_LIBKCDDB=yes
+ )
+
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+
+ #Junk all the files that overlap with libkcddb.
+ #It would be cleaner not to let them install at all, but I wasn't
+ #able to pull that off.
+ rm -r ${D}/usr/trinity/14/share/apps/tdeconf_update/kcmcddb-emailsettings.upd
+ rm -r ${D}/usr/trinity/14/share/config.kcfg/libkcddb.kcfg
+ rm -r ${D}/usr/trinity/14/share/applications/tde/libkcddb.desktop
+ rm -r ${D}/usr/trinity/14/include/libkcddb/
+ rm -r ${D}/usr/trinity/14/lib64/libkcddb*
+ rm -r ${D}/usr/trinity/14/lib64/trinity/kcm_cddb*
+ rm -r ${D}/usr/trinity/14/lib64/libkcddb*
+}