summaryrefslogtreecommitdiffstats
path: root/trinity-base/kttsd
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/kttsd
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kttsd')
-rw-r--r--trinity-base/kttsd/Manifest1
-rw-r--r--trinity-base/kttsd/kttsd-14.1.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/trinity-base/kttsd/Manifest b/trinity-base/kttsd/Manifest
index f170c6a0..661fbb1c 100644
--- a/trinity-base/kttsd/Manifest
+++ b/trinity-base/kttsd/Manifest
@@ -1 +1,2 @@
DIST tdeaccessibility-trinity-14.1.1.tar.xz 6192024 BLAKE2B 42356922784a4cf2abde4c0e932faf8bf24dc2829cd1507f4ad81de4615a6abe808cafabd1781e47020a03531b5ddb2478230e05f716e3a23bb72cb0431f6e0e SHA512 4e215d8b0de470b1820bb251e2d9d69eba54e828fb6d94b50e4f5ddf74fe1e8166dcabc48694bcba4ce11e46a8cc37fb3774941ef73c959f280b89ddc652808d
+DIST tdeaccessibility-trinity-14.1.2.tar.xz 6191780 BLAKE2B 5d1a6b4df9a4a97a43418174dfe8779ce69944020f70fab43c4f3ba54e746de0dfa9856a1a73acdf107dd70555217706d0753971b7aabc64d8c9e5330ae86cc0 SHA512 0cf1ec7ae36720db16e502455b90fb949d1d5451a16b211d570c4200ad9819a6250684efac5492e13cba185a1722f7e464cb854a414cff7b770411a983e48bbe
diff --git a/trinity-base/kttsd/kttsd-14.1.2.ebuild b/trinity-base/kttsd/kttsd-14.1.2.ebuild
new file mode 100644
index 00000000..ffaeca9c
--- /dev/null
+++ b/trinity-base/kttsd/kttsd-14.1.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2022-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdeaccessibility"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+TRINITY_NEED_ARTS="optional"
+TSM_EXTRACT_ALSO="kspeechsink"
+inherit trinity-meta-2
+
+DESCRIPTION="TDE text-to-speech subsystem"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="akode +alsa epos festival flite freetts hadifix kate"
+REQUIRED_USE="|| ( akode alsa arts )"
+
+DEPEND=" akode? ( ~media-libs/akode-${PV} )
+ alsa? ( media-libs/alsa-lib )
+ ~trinity-base/kcontrol-${PV}"
+RDEPEND=" ${DEPEND}
+ epos? ( app-accessibility/epos )
+ flite? ( app-accessibility/flite )
+ freetts? ( app-accessibility/freetts )
+ hadifix? ( app-accessibility/mbrola )
+ kate? ( trinity-base/kate )"
+
+# Missing dependencies:
+# festival? ( app-accessibility/festival )
+# hadifix? ( app-accessibility/txt2pho )
+# Note: tha flags should me masked
+
+pkg_setup() {
+ if use festival; then
+ ewarn
+ ewarn "app-accessibility/festival was removed from portage. In order to use it"
+ ewarn "as your TTS engine you will have to provide the festival binary yourself."
+ fi
+
+ if use hadifix; then
+ ewarn
+ ewarn "Hadifix TTS engine requires txt2pho utility which is not currently in portage."
+ ewarn "In order to use Hadifix as your TTS engine you will have to provide the binary yourself."
+ fi
+
+ elog "Besides built-in support for several engines kttsd includes generic 'Command'"
+ elog "module which may utilize other 3rd-party TTS engines like:"
+ elog " - app-accessibility/espeak-ng"
+ elog " - app-accessibility/rhvoice"
+ elog " - app-accessibility/speech-dispatcher"
+ elog "and others. You are welcome to install one of them."
+
+ trinity-meta-2_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_AKODE="$(usex akode)"
+ -DBUILD_KTTSD_FESTIVAL="$(usex festival)"
+ -DBUILD_KTTSD_EPOS="$(usex epos)"
+ -DBUILD_KTTSD_FLITE="$(usex flite)"
+ -DBUILD_KTTSD_FREETTS="$(usex freetts)"
+ -DBUILD_KTTSD_HADIFIX=$(usex hadifix)
+ -DBUILD_KTTSD_KATE="$(usex kate)"
+ -DBUILD_KTTSD_COMMAND=ON
+ -DWITH_GSTREAMER=OFF # gstreamer support is not really finished
+ )
+
+ trinity-meta-2_src_configure
+}