summaryrefslogtreecommitdiffstats
path: root/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerSlávek Banko <slavek.banko@axis.cz>2024-04-29 00:52:31 +0200
commit94ec1d06986a97431ffc44951e92b075da19b93b (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
parent08657933720cc4345cdf62e1d42f199d8225e458 (diff)
downloadtde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.tar.gz
tde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 30335515923be5f5ee02981121d2cdb6ad89978d)
Diffstat (limited to 'trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild')
-rw-r--r--trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild b/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
new file mode 100644
index 00000000..62eeb8f6
--- /dev/null
+++ b/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_NEED_ARTS="optional"
+TRINITY_MODULE_NAME="tdeaddons"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2 db-use
+
+DESCRIPTION="Various plugins for Noatun"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="sdl berkdb"
+
+COMMON_DEPEND="
+ ~trinity-base/noatun-${PV}
+ berkdb? ( =sys-libs/db-4*:= )
+"
+DEPEND="${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl )
+"
+RDEPEND="${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl[X] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SDL="$(usex sdl)"
+ )
+
+ if use berkdb; then
+ local mycmakeargs+=(
+ -DWITH_BERKELEY_DB=ON
+ -DBERKELEY_DB_LIBS="$(db_libname)"
+ -DBERKELEY_DB_INCLUDE_DIRS="${ESYSROOT}$(db_includedir)"
+ )
+ else
+ local mycmakeargs+=(
+ -DWITH_BERKELEY_DB=OFF
+ )
+ fi
+
+ trinity-meta-2_src_configure
+}