summaryrefslogtreecommitdiffstats
path: root/trinity-base/noatun-plugins
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/noatun-plugins
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/noatun-plugins')
-rw-r--r--trinity-base/noatun-plugins/Manifest1
-rw-r--r--trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/trinity-base/noatun-plugins/Manifest b/trinity-base/noatun-plugins/Manifest
index d40fb180..a0a24462 100644
--- a/trinity-base/noatun-plugins/Manifest
+++ b/trinity-base/noatun-plugins/Manifest
@@ -1 +1,2 @@
DIST tdeaddons-trinity-14.1.1.tar.xz 1464700 BLAKE2B 5818dd1f2434694e0acdc0694d3a17d5fb1f1c1f6eeb4b77220e721fe8464a87721494ead8547d3e41cf17e626b3dd7ab049089e0b2b509e0772f85227313084 SHA512 bebb96b5261ae607d5e405ab33dff65c1792b5b34fdb86d96e2ce433bbe9a8c97c5114deab61b5e09688d59f09cd7d75b81007c1029f2412d397980a942d9100
+DIST tdeaddons-trinity-14.1.2.tar.xz 1464932 BLAKE2B 27bf3ab510b4ca20d51b7d0183077c16901ad8c04582bea54bae6f943a4706875a0c5067a8d9943138fee5c9227a9bb68f14e89a57f6348d27a26518afbf74a4 SHA512 b50173d74933893f76471893569941dffff8ce9f1152b76411d4c92559c96fc1e8b4ddb89b21a88961d678efcbd42bd2ea9dc94735a95aee3ef89e2c895ce51c
diff --git a/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild b/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
new file mode 100644
index 00000000..62eeb8f6
--- /dev/null
+++ b/trinity-base/noatun-plugins/noatun-plugins-14.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_NEED_ARTS="optional"
+TRINITY_MODULE_NAME="tdeaddons"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2 db-use
+
+DESCRIPTION="Various plugins for Noatun"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="sdl berkdb"
+
+COMMON_DEPEND="
+ ~trinity-base/noatun-${PV}
+ berkdb? ( =sys-libs/db-4*:= )
+"
+DEPEND="${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl )
+"
+RDEPEND="${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl[X] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SDL="$(usex sdl)"
+ )
+
+ if use berkdb; then
+ local mycmakeargs+=(
+ -DWITH_BERKELEY_DB=ON
+ -DBERKELEY_DB_LIBS="$(db_libname)"
+ -DBERKELEY_DB_INCLUDE_DIRS="${ESYSROOT}$(db_includedir)"
+ )
+ else
+ local mycmakeargs+=(
+ -DWITH_BERKELEY_DB=OFF
+ )
+ fi
+
+ trinity-meta-2_src_configure
+}