summaryrefslogtreecommitdiffstats
path: root/trinity-base/noatun-plugins
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-16 14:31:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-29 23:14:18 +0100
commite1542e32c7516e9f43122d98c361fb9739b3ddd6 (patch)
tree89f6e9db473f1ecb4061cb87aeb031fd4502d422 /trinity-base/noatun-plugins
parent84844feab1702612fef4ccc56bb4b6b14a2fda63 (diff)
downloadtde-packaging-gentoo-e1542e32c7516e9f43122d98c361fb9739b3ddd6.tar.gz
tde-packaging-gentoo-e1542e32c7516e9f43122d98c361fb9739b3ddd6.zip
trinity-base/noatun-plugins: need-arts -> TRINITY_NEED_ARTS
- We no longer have to tip-toe around assigning IUSE, DEPEND and RDEPEND - Fix wrong phase function override src_compile() -> src_configure() - local mycmakeargs Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'trinity-base/noatun-plugins')
-rw-r--r--trinity-base/noatun-plugins/noatun-plugins-9999.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/trinity-base/noatun-plugins/noatun-plugins-9999.ebuild b/trinity-base/noatun-plugins/noatun-plugins-9999.ebuild
index f46c8aa8..16558023 100644
--- a/trinity-base/noatun-plugins/noatun-plugins-9999.ebuild
+++ b/trinity-base/noatun-plugins/noatun-plugins-9999.ebuild
@@ -3,41 +3,39 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdeaddons"
+TRINITY_MODULE_NAME="tdeaddons"
+TRINITY_NEED_ARTS="optional"
inherit trinity-meta-2 db-use
-need-arts optional
+DESCRIPTION="Various plugins for Noatun"
-DESCRIPTION="Various plugins for Noatun."
-
-IUSE+=" sdl berkdb"
+IUSE="sdl berkdb"
COMMON_DEPEND="
~trinity-base/noatun-${PV}
berkdb? ( =sys-libs/db-4*:= )
"
-DEPEND+=" ${COMMON_DEPEND}
+DEPEND="${COMMON_DEPEND}
sdl? ( media-libs/libsdl )
"
-
-RDEPEND+=" ${COMMON_DEPEND}
+RDEPEND="${COMMON_DEPEND}
sdl? ( media-libs/libsdl[X] )
"
-src_compile() {
- mycmakeargs=(
+src_configure() {
+ local mycmakeargs=(
-DWITH_SDL="$(usex sdl)"
)
if use berkdb; then
- mycmakeargs=( "${mycmakeargs[@]}"
+ mycmakeargs+=(
-DWITH_BERKELEY_DB=ON
-DBERKELEY_DB_LIBS="$(db_libname)"
-DBERKELEY_DB_INCLUDE_DIRS="${ROOT}$(db_includedir)"
)
else
- mycmakeargs=( "${mycmakeargs[@]}"
+ mycmakeargs+=(
-DWITH_BERKELEY_DB=OFF
)
fi