summaryrefslogtreecommitdiffstats
path: root/trinity-base/noatun/noatun-14.0.13.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-base/noatun/noatun-14.0.13.ebuild
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/noatun/noatun-14.0.13.ebuild')
-rw-r--r--trinity-base/noatun/noatun-14.0.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/trinity-base/noatun/noatun-14.0.13.ebuild b/trinity-base/noatun/noatun-14.0.13.ebuild
new file mode 100644
index 00000000..8318685e
--- /dev/null
+++ b/trinity-base/noatun/noatun-14.0.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdemultimedia"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+TSM_EXTRACT_ALSO="arts mpeglib"
+inherit trinity-meta-2
+
+DESCRIPTION="Media player featuring audio effects, graphic equalizer and network transparency"
+HOMEPAGE="https://trinitydesktop.org/"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="~trinity-base/tdemultimedia-arts-${PV}[mpeg]"
+DEPEND="${RDEPEND}
+ x11-libs/libXext
+"
+
+src_prepare() {
+ sed -i 's/mpeg-shared/mpeg/' "${S}/${PN}/CMakeLists.txt" || die
+ sed -i 's/mpeg-shared/mpeg Xext/' "${S}/${PN}/library/noatunarts/CMakeLists.txt"
+ trinity-meta-2_src_prepare
+}
+
+#KMCOMPILEONLY="arts"
+
+#src_compile() {
+# # fix bug 128884
+# filter-flags -fomit-frame-pointer
+# kde-meta_src_compile
+#}