summaryrefslogtreecommitdiffstats
path: root/trinity-base/quanta/quanta-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/quanta/quanta-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/quanta/quanta-14.1.0.ebuild')
-rw-r--r--trinity-base/quanta/quanta-14.1.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/trinity-base/quanta/quanta-14.1.0.ebuild b/trinity-base/quanta/quanta-14.1.0.ebuild
new file mode 100644
index 00000000..7ca13771
--- /dev/null
+++ b/trinity-base/quanta/quanta-14.1.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdewebdev"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+TSM_EXTRACT_ALSO="lib translations"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="Web development environment for TDE [Trinity]"
+HOMEPAGE="https://trinitydesktop.org/"
+
+SRC_URI+="
+ http://download.sourceforge.net/quanta/html.tar.bz2
+ http://download.sourceforge.net/quanta/css.tar.bz2
+ http://download.sourceforge.net/quanta/javascript.tar.bz2
+ http://download.sourceforge.net/quanta/php_manual_en_20030401.tar.bz2"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+DEPEND="
+ app-text/htmltidy
+ dev-libs/libxml2
+ dev-libs/libxslt
+ ~trinity-base/klinkstatus-${PV}
+ ~trinity-base/kommander-${PV}
+ ~trinity-base/tdefilereplace-${PV}
+"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ trinity-meta-2_src_unpack
+ unpack php_manual_en_20030401.tar.bz2
+ cd "${S}"
+ unpack css.tar.bz2
+ unpack javascript.tar.bz2
+ unpack html.tar.bz2
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ dodir ${TDEDIR}/share/apps/quanta/doc
+
+ for i in css html javascript ; do
+ pushd $i >/dev/null || die
+ ./install.sh <<EOF
+${D}/${TDEDIR}/share/apps/quanta/doc
+EOF
+ popd >/dev/null || die
+ rm -rf $i || die
+ done
+ cp -rf "${WORKDIR}/php" "${WORKDIR}/php.docrc" "${D}/${TDEDIR}/share/apps/quanta/doc" || die
+
+ trinity-meta-2_src_install
+}