summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdeaddons-doc
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-10 03:11:17 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:34:35 +0000
commit59a5a64b42421e246b5b90bf0d944299346faa7e (patch)
tree532903ae659fdf852560d006b8a2c680701f2cc1 /trinity-base/tdeaddons-doc
parent83310ab2e1e23459df24e5fab68d3b969e301450 (diff)
downloadtde-packaging-gentoo-59a5a64b42421e246b5b90bf0d944299346faa7e.tar.gz
tde-packaging-gentoo-59a5a64b42421e246b5b90bf0d944299346faa7e.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 6.
This time: tdeartwork-meta, tdeartwork-emoticons, tdeartwork-icon-themes, tdeartwork-icewm-themes, tdeartwork-tdescreensaver, tdeartwork-twin-styles, tdeartwork-kworldclock, tdeartwork-sounds, tdeartwork-styles, tdeartwork-wallpapers, atlantikdesigner, tdeaddons-doc, kaddressbook-plugins, kate-plugins, kicker-applets, knewsticker-scripts, konq-plugins, ksig, renamedlg-plugins, tdeaddons-tdefile-plugins, and tdeaddons-meta Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdeaddons-doc')
-rw-r--r--trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild b/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
index adf21c3f..2f890696 100644
--- a/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
+++ b/trinity-base/tdeaddons-doc/tdeaddons-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdeaddons"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Documentaion for tdeaddons-derived packages"
-KEYWORDS=""
-IUSE+=""
+
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}