summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdebase-tdeioslaves
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-08 03:32:42 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:30:56 +0000
commit6bbd4e98cf417d8be962fb2896b95dac248f2438 (patch)
treefd33db170ae706273cfcfce10fe4f79f4012102d /trinity-base/tdebase-tdeioslaves
parent084b0b62ec405a29a0b09db92551cf973637478f (diff)
downloadtde-packaging-gentoo-6bbd4e98cf417d8be962fb2896b95dac248f2438.tar.gz
tde-packaging-gentoo-6bbd4e98cf417d8be962fb2896b95dac248f2438.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 1.
This time: kcminit, kcontrol, kdesktop, kicker, konqueror, libkonq, tdebase-data, tdebase-meta, tdm, and tdebase-tdeioslaves Also: Add additional dependency for rpcgen. Add additional USE flag for tdehwlib. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdebase-tdeioslaves')
-rw-r--r--trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
index 130e9f02..88bfc776 100644
--- a/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
+++ b/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
@@ -1,41 +1,37 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta
+inherit trinity-meta-2
TSM_EXTRACT="tdeioslave"
DESCRIPTION="Generic Trinity TDEIOslaves"
-KEYWORDS=
IUSE="samba ldap sasl openexr +tdehw"
DEPEND="x11-libs/libXcursor
- openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ net-libs/rpcsvc-proto
+ openexr? ( media-libs/openexr )
samba? ( net-fs/samba )
ldap? ( net-nds/openldap )
sasl? ( dev-libs/cyrus-sasl )"
-RDEPEND="${DEPEND}"
-# CHECKME: optional dependencies
-#DEPEND="
-# >=dev-libs/cyrus-sasl-2
-# x11-apps/xhost
RDEPEND="${DEPEND}
virtual/ssh
- trinity-base/tdeeject:${SLOT}"
+ =trinity-base/tdeeject-${PV}"
src_configure() {
mycmakeargs=(
-DWITH_XCURSOR=ON
- $(cmake-utils_use_with samba SAMBA)
- $(cmake-utils_use_with ldap LDAP)
- $(cmake-utils_use_with sasl SASL)
- $(cmake-utils_use_with openexr OPENEXR)
- $(cmake-utils_use_with tdehw TDEHWLIB)
+ -DWITH_SAMBA="$(usex samba)"
+ -DWITH_LDAP="$(usex ldap)"
+ -DWITH_SASL="$(usex sasl)"
+ -DWITH_OPENEXR="$(usex openexr)"
+ -DWITH_TDEHWLIB="$(usex tdehw)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}