summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdegraphics-doc
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-09 19:27:13 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:34:05 +0000
commit83310ab2e1e23459df24e5fab68d3b969e301450 (patch)
tree1af33a73c2a27a050aa12457cfae322ed75a4a91 /trinity-base/tdegraphics-doc
parent42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083 (diff)
downloadtde-packaging-gentoo-83310ab2e1e23459df24e5fab68d3b969e301450.tar.gz
tde-packaging-gentoo-83310ab2e1e23459df24e5fab68d3b969e301450.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 5.
This time: ark, kamera, kcoloredit, kdvi, kedit, kfax, kfloppy, kgamma, kghostview, khexedit, kjots, klaptopdaemon, kmilo, kmrml, kolourpaint, kooka, kpdf, kpovmodeler, kregexpeditor, kruler, ksim, ksnapshot, ksvg, ktimer, kuickshow, kview, kviewshell, libkscan, tdefilereplace, superkaramba, tdegraphics-doc, tdegraphics-meta, tdegraphics-tdefile-plugins, tdeiconedit, tdelirc, tdeutils-doc, tdeutils-meta and tdewallet Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdegraphics-doc')
-rw-r--r--trinity-base/tdegraphics-doc/tdegraphics-doc-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/trinity-base/tdegraphics-doc/tdegraphics-doc-9999.ebuild b/trinity-base/tdegraphics-doc/tdegraphics-doc-9999.ebuild
index 847974ef..fd7f54d1 100644
--- a/trinity-base/tdegraphics-doc/tdegraphics-doc-9999.ebuild
+++ b/trinity-base/tdegraphics-doc/tdegraphics-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdegraphics"
-inherit trinity-meta
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdegraphics-derived packages"
-DESCRIPTION="Documentaion for kdegraphics-derived packages"
-KEYWORDS=
-IUSE=""
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}