summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdemultimedia-meta
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 16:16:34 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 14:22:25 +0100
commit58de8263fcaa4acba0df369a017c4a29cacfd99f (patch)
treee3dcd318dc5264036454a9bf103474870242f69c /trinity-base/tdemultimedia-meta
parent9b3eddb24c48f766b7d8b09e964b9c321a976e1a (diff)
downloadtde-packaging-gentoo-58de8263fcaa4acba0df369a017c4a29cacfd99f.tar.gz
tde-packaging-gentoo-58de8263fcaa4acba0df369a017c4a29cacfd99f.zip
14.0.7 and 14.0.8 ebuilds for roughly 40% of tdemultimedia (see the tdemultimedia-meta ebuild for what is missing and why). Note that these have been test-built in minimalist configurations only and additional TSM_EXTRACT_ALSO entries may be needed. Also, some deps that used to be optional aren't anymore.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/tdemultimedia-meta')
-rw-r--r--trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.7.ebuild38
-rw-r--r--trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.8.ebuild38
2 files changed, 76 insertions, 0 deletions
diff --git a/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.7.ebuild b/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.7.ebuild
new file mode 100644
index 00000000..f378cda0
--- /dev/null
+++ b/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit trinity-functions-2
+
+set-trinityver
+DESCRIPTION="tdemultimedia - merge this to pull in all tdemultimedia-derived packages"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+SLOT="${TRINITY_VER}"
+IUSE="arts"
+#USE not currently in use: xine
+
+RDEPEND="arts? ( ~trinity-base/juk-${PV}
+ ~trinity-base/kaboodle-${PV}
+ ~trinity-base/tdemultimedia-arts-${PV} )
+ ~trinity-base/kmix-${PV}
+ ~trinity-base/tdemid-${PV}
+ ~trinity-base/tdemultimedia-kappfinder-data-${PV}
+ ~trinity-base/tdemultimedia-tdefile-plugins-${PV}"
+
+#Needs kscd, which we don't yet have an ebuild for, to do anything useful
+# ~trinity-base/tdemultimedia-tdeioslaves-${PV}
+
+#These were in KDE3, but TDE has no ebuilds for them as of Jun 2020
+#arts? ( ~trinity-base/artsplugin-akode-${PV}
+# ~trinity-base/artsplugin-audiofile-${PV}
+# xine? ( ~trinity-base/artsplugin-xine-${PV} )
+# ~trinity-base/kaudiocreator-${PV}
+# ~trinity-base/krec-${PV}
+# ~trinity-base/noatun-${PV} )
+# ~trinity-base/kscd-${PV}
+# ~trinity-base/libkcddb-${PV}
diff --git a/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.8.ebuild b/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.8.ebuild
new file mode 100644
index 00000000..f378cda0
--- /dev/null
+++ b/trinity-base/tdemultimedia-meta/tdemultimedia-meta-14.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit trinity-functions-2
+
+set-trinityver
+DESCRIPTION="tdemultimedia - merge this to pull in all tdemultimedia-derived packages"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+SLOT="${TRINITY_VER}"
+IUSE="arts"
+#USE not currently in use: xine
+
+RDEPEND="arts? ( ~trinity-base/juk-${PV}
+ ~trinity-base/kaboodle-${PV}
+ ~trinity-base/tdemultimedia-arts-${PV} )
+ ~trinity-base/kmix-${PV}
+ ~trinity-base/tdemid-${PV}
+ ~trinity-base/tdemultimedia-kappfinder-data-${PV}
+ ~trinity-base/tdemultimedia-tdefile-plugins-${PV}"
+
+#Needs kscd, which we don't yet have an ebuild for, to do anything useful
+# ~trinity-base/tdemultimedia-tdeioslaves-${PV}
+
+#These were in KDE3, but TDE has no ebuilds for them as of Jun 2020
+#arts? ( ~trinity-base/artsplugin-akode-${PV}
+# ~trinity-base/artsplugin-audiofile-${PV}
+# xine? ( ~trinity-base/artsplugin-xine-${PV} )
+# ~trinity-base/kaudiocreator-${PV}
+# ~trinity-base/krec-${PV}
+# ~trinity-base/noatun-${PV} )
+# ~trinity-base/kscd-${PV}
+# ~trinity-base/libkcddb-${PV}