summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdepim-wizards
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/tdepim-wizards
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdepim-wizards')
-rw-r--r--trinity-base/tdepim-wizards/Manifest1
-rw-r--r--trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/trinity-base/tdepim-wizards/Manifest b/trinity-base/tdepim-wizards/Manifest
new file mode 100644
index 00000000..d13bb2ac
--- /dev/null
+++ b/trinity-base/tdepim-wizards/Manifest
@@ -0,0 +1 @@
+DIST tdepim-trinity-14.0.11.tar.xz 9387536 BLAKE2B 1d1874fe2bc962214d2a05c87bd75536280a08feb0ea5aaeee843dff145862fa8d43c6c6c29e7a2b304cc25748dc30ba1fb42336e0ed09322b5969a2b3d4c7a5 SHA512 a7f6e2f6f0080cd745d63fec7c573f0b6e8634470cf60985ac2c0d830fc0003c791585730a95e5ca242e3d9d037765be530606b3642a4764536bd07be262be74
diff --git a/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild b/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
new file mode 100644
index 00000000..96fa4e9b
--- /dev/null
+++ b/trinity-base/tdepim-wizards/tdepim-wizards-14.0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TRINITY_SUBMODULE="wizards"
+
+inherit trinity-meta-2
+
+DESCRIPTION="TDEPIM wizards"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/knotes-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/tdepim-tderesources-${PV}"
+RDEPEND="${DEPEND}"
+
+TSM_EXTRACT_ALSO="libtdepim/ tderesources/ kmail/ libkpimidentities/ knotes/ libkcal/ \
+ libemailfunctions/ translations/"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_FLAGS="-L${TDEDIR}/$(get_libdir)"
+ -DWITH_EGROUPWARE=ON
+ -DWITH_KOLAB=ON
+ -DWITH_SLOX=ON
+ -DWITH_GROUPWISE=ON
+ -DWITH_NEWEXCHANGE=ON
+ -DWITH_SCALIX=ON
+ )
+ trinity-meta-2_src_configure
+}