summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdesu/tdesu-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:35:54 +0300
commit30335515923be5f5ee02981121d2cdb6ad89978d (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/tdesu/tdesu-14.1.2.ebuild
parent929431cac813bc953a1e646fe36d1cfbc4a68f4b (diff)
downloadtde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.tar.gz
tde-packaging-gentoo-30335515923be5f5ee02981121d2cdb6ad89978d.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdesu/tdesu-14.1.2.ebuild')
-rw-r--r--trinity-base/tdesu/tdesu-14.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/trinity-base/tdesu/tdesu-14.1.2.ebuild b/trinity-base/tdesu/tdesu-14.1.2.ebuild
new file mode 100644
index 00000000..dca73912
--- /dev/null
+++ b/trinity-base/tdesu/tdesu-14.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity gui for su(1) or sudo"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="sudo"
+
+DEPEND="sudo? ( app-admin/sudo )"
+RDEPEND="${DEPEND}"
+
+src_configure () {
+ local mycmakeargs=(
+ -DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
+ )
+
+ trinity-meta-2_src_configure
+}
+
+pkg_postinst () {
+ if use sudo; then
+ einfo "Remember that the sudo use flag sets only the default superuser command."
+ einfo "It can be overriden on a user-level by adding:"
+ einfo " [super-user-command]"
+ einfo " super-user-command=su"
+ einfo "to the kdeglobals config file, which is usually"
+ einfo "located in the ~/.trinity/share/config/ directory."
+ fi
+}