summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdesu
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-08 19:09:38 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:33:02 +0000
commit13f3b6432f125802f4fee3827d2b0e882a0a8dfe (patch)
tree49224d9604584a2ad827891fd6667cbf412a6385 /trinity-base/tdesu
parente05ee6fdde9c2c4b00dbe2c4e5a82da8141a64e2 (diff)
downloadtde-packaging-gentoo-13f3b6432f125802f4fee3827d2b0e882a0a8dfe.tar.gz
tde-packaging-gentoo-13f3b6432f125802f4fee3827d2b0e882a0a8dfe.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 3.
This time: kpager, krootbacking, ksplashml, kstart, ksystraycmd, kxkb, nsplugins, tdebase-starttde, tdedebugdialog, tdeeject, tdepasswd, tdeprint, tdescreensaver, tdesu and tqt3integration Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdesu')
-rw-r--r--trinity-base/tdesu/tdesu-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/trinity-base/tdesu/tdesu-9999.ebuild b/trinity-base/tdesu/tdesu-9999.ebuild
index 9238d041..8efeccc6 100644
--- a/trinity-base/tdesu/tdesu-9999.ebuild
+++ b/trinity-base/tdesu/tdesu-9999.ebuild
@@ -1,33 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity gui for su(1) or sudo"
-KEYWORDS=
IUSE="sudo"
-DEPEND+=" sudo? ( app-admin/sudo )"
-RDEPEND+=" ${DEPEND}"
+DEPEND="sudo? ( app-admin/sudo )"
+RDEPEND="${DEPEND}"
src_configure () {
mycmakeargs=(
- $(cmake-utils_use_with sudo SUDO_KDESU_BACKEND)
+ -DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
pkg_postinst () {
if use sudo; then
- einfo "Remember sudo use flag sets only the defauld value"
+ einfo "Remember that the sudo use flag sets only the default superuser command."
einfo "It can be overriden on a user-level by adding:"
einfo " [super-user-command]"
einfo " super-user-command=su"
- einfo "To the kdeglobal config file which is should be usually"
+ einfo "to the kdeglobal config file which is should be usually"
einfo "located in the ~/.trinity/share/config/ directory."
+
fi
}