summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdesu
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/tdesu
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdesu')
-rw-r--r--trinity-base/tdesu/Manifest1
-rw-r--r--trinity-base/tdesu/tdesu-14.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-base/tdesu/Manifest b/trinity-base/tdesu/Manifest
index 18b996f6..0a2863b1 100644
--- a/trinity-base/tdesu/Manifest
+++ b/trinity-base/tdesu/Manifest
@@ -1 +1,2 @@
DIST tdebase-trinity-14.0.13.tar.xz 30564196 BLAKE2B 0055a5bc7c3e5abc7df6afaf05da2d3b96cb217d191355b76e9ca19fe32c550a0d25dd281ad0d19fc0e8c074793dcfb4b15a59a53f1ff0c11d3351eb93208dcf SHA512 78328f17acb8372ce6b29d18604329191863003bf8d8b89c0bad55744c78dc3ba3f4ec7593933f5ccef4460c2267de82dff06f42fdcc1a4d8d9276c45dac7502
+DIST tdebase-trinity-14.1.0.tar.xz 30722632 BLAKE2B 1f4b87be37730aaa93fc579c130d7af7c408d20512ff8642d8313abaa7ccf6a012c8b52c595641e8ff820f709d68471224f2ceb1f898769b36e386345924b948 SHA512 8fcbb5d4bbaefc9acafa5d1926d6f22b1c087a7af63f0d9e2438c95730e82e6d6e9555afdf336bd01c296adedef5665c571d00c6738d071ed069243d47f30674
diff --git a/trinity-base/tdesu/tdesu-14.1.0.ebuild b/trinity-base/tdesu/tdesu-14.1.0.ebuild
new file mode 100644
index 00000000..72a37cf7
--- /dev/null
+++ b/trinity-base/tdesu/tdesu-14.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity gui for su(1) or sudo"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="sudo"
+
+DEPEND="sudo? ( app-admin/sudo )"
+RDEPEND="${DEPEND}"
+
+src_configure () {
+ local mycmakeargs=(
+ -DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
+ )
+
+ trinity-meta-2_src_configure
+}
+
+pkg_postinst () {
+ if use sudo; then
+ einfo "Remember that the sudo use flag sets only the default superuser command."
+ einfo "It can be overriden on a user-level by adding:"
+ einfo " [super-user-command]"
+ einfo " super-user-command=su"
+ einfo "to the kdeglobals config file, which is usually"
+ einfo "located in the ~/.trinity/share/config/ directory."
+ fi
+}